Auto-connect to WPA2 protected 11g network after sleep or reboot?

Discussion in 'macOS' started by theBB, Mar 19, 2008.

  1. theBB macrumors 68020

    theBB

    Joined:
    Jan 3, 2006
    #1
    I have recently switched to WPA2 encryption on my Airport Express (11b/g version) network from WEP. Everything works for the most part, but my iMac does not auto-connect after waking from sleep or reboot any more. I have to manually select the network from the airport menu bar. I did not have this problem when it had WEP. I am running 10.4.11 on an intel iMac CD. Any ideas?

    BTW, I have checked my System Preferences -> Network -> Airport item and my network is the only one listed in my Preferred list and it is set to connect by default and if it cannot find any of the networks it is supposed to keep trying to find it. (I had it set to join an open one, but the problem did not get solved after changing this setting.) I have also deleted com.apple.networkconfig.plist, toggled the settings on the airport and tried adding the WPA2 password to my keychain, so far no improvement...
     
  2. tersono macrumors 68000

    tersono

    Joined:
    Jan 18, 2005
    Location:
    UK
    #2
    I've had a similar issue in the past, which I solved by deleting the keychain entry for the network, then removing the network from the network prefpane and re-creating it from scratch. At that point it started connecting automatically and I haven't had a problem since...
     
  3. theBB thread starter macrumors 68020

    theBB

    Joined:
    Jan 3, 2006
    #3
    Well, mine was not in the keychain when the problems started and I believe I have removed my network from the preferred networks list and added it back again although I am not absolutely sure, maybe I should try it again. Is that what you changed in network preferences?

    By the way, my location is "Automatic".
     

Share This Page