Auto-correct in several languages

Discussion in 'OS X El Capitan (10.11)' started by Jardins de Vin, Mar 9, 2016.

  1. Jardins de Vin macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #1
    The Mac I use with El Capitan is used for various things where I need to type stuff in a total of four languages, until recently everything worked fine (Yosemite was installed until not too long ago).

    Basically, it would recognise almost instantly in which language I type and would start correcting me.

    What's annoying me now is that when I start typing something in a different language, it doesn't seem to 'accept' that language and it starts correct stuff while it's all correctly written. It thinks I'm trying in a different language and it starts correcting it as if it was the other language. See what I mean?

    Anyone know what I can do here? It's very frustrating and there's one language I can't even properly type in.
     
  2. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #2
    when you change language, have you tried switching to the desired language and keyboard from "System Preferences" before starting?
     
  3. Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #3
    Actually, I don't have different keyboards (and never had). I only have different languages. My Mac is set in one language (probably the first in the preferences list) and the others are corrected automatically. So it's as if I had just different dictionaries and auto-correct.

    And it's not possible to change language I think. I have added them all to the list, in the order which I am using the most. The last one in the list is the one I have the most issues with. It's as if it wasn't on the list at all.

    (On the iPad it's different, you actually have to change language, it's annoying but it works.)
     
  4. JohnS0007 macrumors newbie

    JohnS0007

    Joined:
    Mar 9, 2016
    #4
    That stupid language corrector is broken since Lion. I tried to get it fix, completed reports, showed video and so on. Got it better with El Captain, but still broken. Only in Snow Leopard it was working perfectly. I speak 3 languages. If I write an english word in a french sentence, it would not properly detect the error as the word does exist in english. It will not underline the unknown word in french, but if I right click it, it will give me suggestion. The same thing with Russian language. If I write a word that does exist in Bulgarian, for example, it will not underline it in red. But it will still give me suggestion of how to correct it if I right click on it. It will work well if the system language is the same as the language you type.

    Here how you can try in TextEdit:

    If your system is in english, here is a french sentence: Voici le correcteur automatic en action.

    Right click the word automatic and it will suggest automatique, as the word automatic does not exist in french. But it did not underline it. So hard to see the errors.

    AND NOBODY CARES AT APPLE TO FIX IT!!!

    Like I said, I completed developer reports, sent feedbacks, showed this in action on video, sent emails to Apple staff. But sadly, no one cares. C'mon!
     
  5. Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe
    #5
    I have EXACTLY the same problems! It is so annoying! I think the main reason Apple doesn't care about this is that we are a minority to speak so many different languages in the first place.

    I tried the sentence you posted, and in fact, like you said, it suggests to correct automatic, but does not underline it. (I have french in my settings as well). After that, it randomly underline "le" in blue. When I clicked on it, it didn't suggest me anything. It is just retarded.

    But these are the minor problems I have…
    My problem is that one language is completely IGNORED! It's as if I had not even set it in my settings.

    I don't know if you have an iPhone or iPad, but on these devices the auto-correct works very well. If you do have one of these devices, and they're set to auto-correct, and you have several languages set, imagine following: You have set the language to Russian, but now start typing in french. It will correct every single word you type, because it will try to turn all these fresh words into Russian words.

    This is what it does to me. It's a catastrophe…
     
  6. AlliFlowers Contributor

    AlliFlowers

    Joined:
    Jan 1, 2011
    Location:
    L.A. (Lower Alabama)
    #6
    What program are you using to type? I only type in two languages, but have not encountered this problem.
     
  7. Jardins de Vin thread starter macrumors 6502a

    Jardins de Vin

    Joined:
    Nov 6, 2012
    Location:
    Europe

Share This Page