Auto-Correct Problems with "IM"

Discussion in 'iPhone' started by yanathin, Jul 1, 2009.

  1. yanathin macrumors member

    Joined:
    Jan 11, 2006
    #1
    I've been reading how the new 3.0 OS has been a little less lenient on the auto-correction. I'm not sure if other people are encountering this problem, but I'm experiencing an extremely annoying problem. Whenever I type the letters "im" it automatically corrects it to "IM" in all capitals. Not "I'm" or "i'm", and I cannot even figure out how to NOT automatically correct it to just leave it how it is. Has anybody found a work-around for this? It's absolutely ridiculously annoying and is enough for me to just turn off auto-correct (even though I really find it useful at other times).
     
  2. abijnk macrumors 68040

    abijnk

    Joined:
    Oct 15, 2007
    Location:
    Los Angeles, CA
    #2
    If you keep correcting it it will figure it out.
     
  3. compg318 macrumors regular

    Joined:
    Dec 1, 2008
    #3
    I don't expirence that, however you can reset your Keyboard Dictionary

    Settings > General > Reset > Reset Keyboard Dictionary.
     
  4. yanathin thread starter macrumors member

    Joined:
    Jan 11, 2006
    #4
    I've reset my dictionary and everything. It still insists on correcting it, no matter how many times I tell it not to...
     
  5. yanathin thread starter macrumors member

    Joined:
    Jan 11, 2006
    #5
    Solved it! In case anybody else has a problem like this, I had a contact with the last name set as IM. So this means that the new 3.0 OS adds contact names to the dictionary automatically.
     
  6. daonesteven macrumors 6502

    Joined:
    Aug 7, 2007
    Location:
    Baltimore, MD
    #6
    yea I have someone on my contacts with the last name "Im" and it auto corrects I'm as Im
     

Share This Page