Auto-sleep requires longer time then chosen

Discussion in 'macOS' started by DennisMadsen, Aug 7, 2011.

  1. DennisMadsen, Aug 7, 2011
    Last edited: Aug 8, 2011

    DennisMadsen macrumors regular

    Joined:
    Sep 21, 2010
    #1
    Yesterday I did a clean install of Mac OS X Lion on my MBP 13", medio 2010. I have noticed that it, in case of inactivity, takes longer time doing into computer auto-sleep than I have chosen in Energy Saver in Preferences.

    If I set computer sleet to 1 minute, in really takes 6 minutes. 5 minutes takes 7 minutes and 10 takes 12 minutes.

    Why?
     
  2. Quad5Ny macrumors 6502a

    Quad5Ny

    Joined:
    Sep 13, 2009
    Location:
    New York, USA
    #2
    What does it say if you open up Terminal and type "pmset -g" (if your on battery or plugged in, this will show different values)?
     
  3. DennisMadsen thread starter macrumors regular

    Joined:
    Sep 21, 2010
    #3
    Here is the output:

    Code:
    Dennis-Madsens-MacBook-Pro:~ dennis$ pmset -g
    Active Profiles:
    Battery Power		-1*
    AC Power		-1
    Currently in use:
     halfdim	1
     sms		1
     panicrestart	157680000
     hibernatefile	/var/vm/sleepimage
     disksleep	10
     sleep		1
     hibernatemode	3
     ttyskeepawake	1
     displaysleep	1
     acwake		0
     lidwake	1
    Dennis-Madsens-Mac
    In Energy Saver I chose 1 minute for both display and computer sleep. Is it a problem, that the disksleep is 10 minutes?
     
  4. talmy macrumors 601

    talmy

    Joined:
    Oct 26, 2009
    Location:
    Oregon
    #4
    One of the bugs I've got after conversion is one system won't auto-sleep at all. I've converted 4 systems and only one is misbehaving.

    There could be some activity keeping these systems awake longer than they should. There's a knowlegebase article on this with steps that should be taken. (Alas, didn't do any good for me, but might for the OP.)

    http://support.apple.com/kb/HT1776
     
  5. DennisMadsen thread starter macrumors regular

    Joined:
    Sep 21, 2010
    #5
    Is there a way to monitor which application doing disk activity?
     
  6. Quad5Ny macrumors 6502a

    Quad5Ny

    Joined:
    Sep 13, 2009
    Location:
    New York, USA
    #6
    First try doing a SMC reset, if that doesnt work then open up Terminal and type "sudo pmset -a ttyskeepawake 0"

    ttyskeepawake - prevent idle system sleep when any tty (e.g. remote login session) is ’active’. A tty is ’inactive’ only when its idle time exceeds the system sleep timer.
     
  7. DennisMadsen thread starter macrumors regular

    Joined:
    Sep 21, 2010
    #7
    Thanks for your reply.

    I'm running on battery and computer sleep are set to 5 minutes.
    I did a SMC reset. But still it took ~13 minutes to sleep. The same after I disabled the ttyskeepawake.
     

Share This Page