auto Space switching, nuisance!!

Discussion in 'macOS' started by NewGenAdam, Jan 14, 2010.

?

automatic Space changing:

  1. is so annoying, I know

    4 vote(s)
    36.4%
  2. is just about tolerable

    1 vote(s)
    9.1%
  3. is so trivial anyone who cares is quite anal

    6 vote(s)
    54.5%
  1. NewGenAdam macrumors 6502

    Joined:
    Jun 29, 2008
    #1
    so I love Spaces. Combined with Exposé my desktop real-estate is effectively enlarged.

    But I find it so annoying how OS X automatically switches to a Space when something loads: an Application opening, a webpage completely loading...
    I may open an App or reload a webpage then change Spaces.

    I neither expect nor want to be thrown back to the page I just left mere seconds later!
    It's annoying and I can't find any resolution...
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Sounds like you have some weird application assignments for Spaces. Change that in the System Preferences.
     
  3. NewGenAdam thread starter macrumors 6502

    Joined:
    Jun 29, 2008
    #3
    yes, I have set up all my apps to their own spaces.

    Now I'm starting to think that's weird; 100% of people in the (limited) sample think I'm anal =/
     
  4. Aikiman macrumors member

    Aikiman

    Joined:
    Jan 24, 2008
    #4
    solution?

    Is there a solution to this? Because this is actually really infuriating not anal. I have my apps assigned as well but the main problem is Maya 3D app. If Im running a disc cache or simulation it updates every frame which is about every 10 seconds. This means every ten seconds I have spaces automatically switch back to the space that displays Maya which means I cant email, browse or doing like write this post properly, hahaha. This needs to be fixed with a preference option.

    Or perhaps somebody knows of a hidden terminal command?

    10.5.8
     
  5. NewGenAdam thread starter macrumors 6502

    Joined:
    Jun 29, 2008
    #5

    thank you for agreeing, it's so annoying!
    Afraid I can't say it's resolved yet, although the issue is out of mind as I'm currently on a PC after my mac had an accident with some tea. Not that the PC is problem free...

    My hope is they'll add an option in an update. Failing that I can't imagine it's impossible to get a custom preference pane disabling it
     
  6. Nero Wolfe macrumors regular

    Nero Wolfe

    Joined:
    Oct 28, 2007
    Location:
    Atlanta, GA
    #6
    You could try: adding an entry to for Maya in spaces preferences and select 'Every Space' under the 'spaces' column. Don't know if it would work or if you have tried it already or not...
     
  7. ergdegdeg Moderator emeritus

    ergdegdeg

    Joined:
    Oct 13, 2007
    #7
    There's a terminal command for Leopard, but I haven't tried/found one for Snow Leopard yet.

    Let me find it again.

    Here it is for Leopard: macosxhints.com. As far as I remember, it disables any auto-switching.
     
  8. mac2x macrumors 65816

    Joined:
    Sep 19, 2009
    #8
    The other thing you can do is right click on the app's dock icon and select "new window"; this window will open in the space you are in. At least in does in Leopard...
     
  9. Aikiman macrumors member

    Aikiman

    Joined:
    Jan 24, 2008
    #9
    mmm I saw that link but didn't really think it applied in my case, but I have given it a whirl and so far it looks as though it has worked! Im hoping I dont come back to report it hasn't, no news in this case will be good news.

    Thanks for the help ppl. :)

    EDIT: Well it is still working which is great, the only thing is now it wont auto switch if I click an icon in the dock, ah well cant win em all I can just use my keyboard shortcuts instead.
     

Share This Page