Auto switch doesn't work

Discussion in 'Apple Watch' started by ManicMarc, Jun 17, 2018.

  1. ManicMarc macrumors 6502

    Joined:
    Jul 1, 2012
    #1
    I have two watches, and auto switch always used to work perfectly. Now, I have this odd behaviour when I switch between watches. Even when manually switching, the watch I've switch to won't hold a bluetooth connection unless I turn Bluetooth off fully on my phone, wait a second and the turn it back on again.
    The phone will show as 'connected' in the bluetooth setting on my phone, but it won't show as connected to the watch.The watch either shows the red 'disconnected' icon if I'm away from WiFi, or connects to WiFi when I'm at home.

    I want to avoid unpairing and repeating both watches if possible, because apart from taking about 4 hours, it means setting up 2x Apple Pay again for each of my cards.

    Any other ideas?

    Preempting any "Why do you have two watches" comments: one is my ancient space grey aluminium sports, the other is my s2 aluminium. Different styles for different days.
     
  2. bruinsrme macrumors 603

    bruinsrme

    Joined:
    Oct 26, 2008
    #2
    This happened when I introduced watch 5.
    Made sure all devices were on the latest and greatest OS
    I shutdown all devices.
    Powered up the phone.
    Powered one the S3 edition watch, wore it for the day and went to work.
    Before leaving leaving for work powered on the S3 SBSS
    Got home, removed the edition and put on the S3 SBSS.
    wore it for an hour, then put on the SS.
    Then removed and put on the S3 SGNike.
    Then removed and put on the S3 silver Nike and slept with it.

    Now the switch works as expected.

    Watch 5 S0 SS was removed from service.
     
  3. matrix07 macrumors 601

    matrix07

    Joined:
    Jun 24, 2010
    #3
    This happens to me a few times.

    Normally turn off & on Airplane mode on the watch force the watch to be connected again,
    If that fails then force restart the watch will solve the problem.

    watchOS 4.3
     
  4. ManicMarc thread starter macrumors 6502

    Joined:
    Jul 1, 2012
    #4
    Thanks guys, I've tried pretty much every combination of airplane mode and rebooting
     
  5. DotCom2 macrumors 601

    Joined:
    Feb 22, 2009
    #5
    Have you checked to make sure the "Auto Switch" control wasn't accidentally disabled? Just a thought.
     
  6. ManicMarc thread starter macrumors 6502

    Joined:
    Jul 1, 2012
    #6
    It's switching in general that doesn't work without first disabling Bluetooth and then enabling on the phone. So manual vs automatic doesn't make any difference
    Frustrating because I often forget and then look down a few hours later realise I haven't been getting notifications because it's not connected.
     
  7. GRT89521 macrumors member

    GRT89521

    Joined:
    Apr 24, 2018
    #7
    I have the same issue with mine. toggle Airplane Mode on the phone seems to resolve. It's annoying, I have a support ticket into Apple on it. Also, I've noticed that my Series 3 Cellular switches fine but my series 2 seems to have trouble with the auto switch.
     

Share This Page

6 June 17, 2018