Autocomplete in FF while using OpenDNS

Discussion in 'Mac Apps and Mac App Store' started by typer16452, Oct 13, 2009.

  1. typer16452 macrumors member

    Joined:
    Jun 7, 2008
    #1
    Does anyone have a workaround to get FF 3.5.3 to autocomplete addresses of a single word (i.e., "google" goes to "http://www.google.com" automatically)…I use OpenDNS and it always goes to some OpenDNS page. (Safari works perfectly btw.)

    OpenDNS people seem to say it's an FF issue so it's not their problem. I tried setting browser.urlbar.autoFill in about:config to "True" but it didn't change anything. Thanks in advance.
     
  2. Middling macrumors regular

    Joined:
    Jan 25, 2009
    #2
    It's not a Firefox issue; the problem is that OpenDNS doesn't return a "doesn't exist" error for domains, instead it redirects to an OpenDNS search/ad page.

    If you sign up for a free OpenDNS account (rather than just using their DNS servers) you can disable this "feature" for your IP address.

    You should find the option under "Dashboard/Settings/YOURNETWORK/Advanced Settings/Domain Typos". Uncheck the "enable typo correction" box.
     
  3. typer16452 thread starter macrumors member

    Joined:
    Jun 7, 2008
    #3
    I have a free OpenDNS account but I don't see the "YourNetwork" option under the Settings (I did get that far). (I even added my current network but I still don't see that option, am I missing something?)

    P.S. Never mind I found the setting (I guess when in all caps it means *your* network settings not the phrase "YourNetwork" :) )

    And the domain(s) go through, thanks!
     

Share This Page