Autocorrect bug (not I to A). Please help!

Discussion in 'iOS 11' started by Twimfy, Nov 5, 2017.

  1. Twimfy, Nov 5, 2017
    Last edited: Nov 5, 2017

    Twimfy macrumors 6502a

    Twimfy

    Joined:
    Sep 11, 2011
    Location:
    UK
    #1
    About a month ago on my iPhone 6S+ running iOS 11 a weird issue started appearing in my autocorrect whereby the word 'is' get's replaced with "I.S". After a chat with Apple support on twitter they suggested a few things which I tried but didn't work. I then took matters into my own hands and started some extreme steps. I knew I had an iPhone X on the way so I thought once it arrives I'll ignore my iCloud backup and start from scratch. That said, 24 hours after owning the iPhone X, the issue is back.

    I spoke to Apple via live chat and they stated that the i turning into A is a known issue, but this one is not and they couldn't recommend any steps to solve it other than text replacment (which doesn't work).

    So far I have tried the following on both devices (every step has been followed by a hard reboot):

    1. Disabling Predictive (never used it anyway).
    2. Toggling autocorrect on and off.
    3. Deleting the dictionary.
    4. Switching to US keyboard instead of UK.
    5. Deleting all of my apps and then reloading them one by one deleting and restarting after each to see if it was a rogue app.
    6. Deleting iCloud data for apps.
    7. Restoring from a backup.
    8. Setting up as new.
    9. Turned off Siri Suggestions for every app.
    10. Deleting all of my contacts.
    11. Searching my Keychain for the word I.S and deleting any results that matched.
    12. Searched my mail for any word matching I.S and deleted it.
    13. Updated to iOS 11.2 Beta from my developer account after Apple Live Chat suggested that similar bugs are under investigation (but they hadn't heard of this one).
    14. Disabled Siri.
    15. Disabled Emoji keyboard.
    16. Removed all of my email accounts.
    Nothing works. It's driving me completely insane. If it were some random word then fine, but such a core part of the English language...I cannot cope and I'm far too innaccurate (and busy) to not use autocorrect.

    Has anyone had a similar problem? Or can anyone recommend any new steps to take? The only thing I can't do is not use my iCloud account. There are 7000+ photos and a hefty music library attached and my @me email address is my primary.

    EDIT: Also the Phone will never learn the word "is" if I dismiss the replacement.

    Here's a video I made of the issue in action:

     
  2. Synergie macrumors 6502a

    Joined:
    Jan 15, 2011
    Location:
    Halifax, Canada
    #2
    When you see that pop up with I.S before you hit space click the x so it will ignore the autocorrect. Meaning before you complete the word. After a few times of doing that, it will relearn that it’s is you want.

    I have trained it to learn certain Punjabi words that I type all the time. It always wanted to autocorrect them to something else but I clicked the X to ignore the autocorrect 3 or 4 times before it got the hint. Now it won’t autocorrect them anymore.
     
  3. Twimfy thread starter macrumors 6502a

    Twimfy

    Joined:
    Sep 11, 2011
    Location:
    UK
    #3
    Forgot to mention that I've been dismissing that suggestion for 5 weeks now. Still hasn't learnt it.
     
  4. Synergie macrumors 6502a

    Joined:
    Jan 15, 2011
    Location:
    Halifax, Canada
    #4
    Hmm sounds like you have the Islamic State bug lol
     
  5. Twimfy thread starter macrumors 6502a

    Twimfy

    Joined:
    Sep 11, 2011
    Location:
    UK
    #5
    I know, it couldn't be a worse forced-typo if it tried. I'm not the tin-foil hat type but if someone is watching all of us then I've probably made a list.
     
  6. Broken Hope macrumors 6502

    Joined:
    Jan 15, 2015
    #6
    My phone is doing It with it and changing it to I.T.

    Restarting fixes it for a short period of time then it starts again, not sure if an app or something is triggering it.
     
  7. Twimfy thread starter macrumors 6502a

    Twimfy

    Joined:
    Sep 11, 2011
    Location:
    UK
    #7
    That was my thought because I get a 30 second grace period before it kicks in. But having run with a clean phone, it appears to be logging into iCloud that triggers the issue.
     
  8. Broken Hope macrumors 6502

    Joined:
    Jan 15, 2015
    #8
    I get a lot longer than 30 seconds but not sure exactly how long, I just hope Apple fix it as it’s annoying.
     
  9. Nikiforidis macrumors member

    Nikiforidis

    Joined:
    Jul 1, 2017
    Location:
    Cyprus
    #9
  10. Broken Hope macrumors 6502

    Joined:
    Jan 15, 2015
  11. Nikiforidis macrumors member

    Nikiforidis

    Joined:
    Jul 1, 2017
    Location:
    Cyprus
    #11
    You are right.
     
  12. WudPPv macrumors newbie

    Joined:
    Nov 6, 2017
    #12
    I'm having the same issue ("is" is replaced by I.S) on my iphone 6. I've tried some things that you have as well but nothing seemed to help apart from installing a 3rd party keyboard. The new keyboard unfortunately crashes every now and then...

     
  13. Broken Hope macrumors 6502

    Joined:
    Jan 15, 2015
    #13
    Managed to last about 2 hours before it started to be changed to I.T again. Would love to know what’s causing it.
     
  14. Broken Hope macrumors 6502

    Joined:
    Jan 15, 2015
    #14
    I'm really wanting to avoid beta's on my X, have you tested with 11.2 beta 2 to see if this fixes it?
     
  15. BrettDS macrumors 65816

    Joined:
    Nov 14, 2012
    Location:
    Orlando
    #15
    I’m having a similar problem, but for me it autocorrects the word Denver to DENVER. I have no idea why. I rarely use the word Denver and I don’t think I’ve ever typed it in all caps. The problem carried over to my iPhone X, even though I set it up as a new device (same appleid though) and it doesn’t happen on my iPad (again, same appleid). I really don’t get it.
     
  16. friednoodles macrumors 6502

    Joined:
    Feb 4, 2014
    #16
    This is a long shot but just one more thing to rule out:

    Although you've tried disabling Siri and turning off Siri Suggestions, have you also tried turning off Siri iCloud Sync? This is a new function in iOS 11 found in your iCloud settings area (where you can turn on/off iCloud sync of Notes, Reminders, Contacts, Photos, etc) simply called "Siri", and it syncs data that Siri learns about you between your devices. It seems like this shouldn't have any influence on the issue you're seeing, but perhaps it's worth turning it off to see if it helps at all.
     
  17. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #17
    It looks like the public version of iOS 11.2 (which was just released) might fix these types of issues: iOS 11.2 Update Fixes 'I.T' Autocorrect Bug
     

Share This Page