Autocorrect only works sometimes?

ncsmith4

macrumors 6502
Original poster
Jul 15, 2007
331
4
Anyone else have this problem? Sometimes the iPhone WILL autocorrect words... and it USUALLY does. But sometimes it just doesnt do it. Usually in the internet. It happens a lot on myspace or facebook.

Anyone?
 

Telp

macrumors 68040
Feb 6, 2007
3,061
16
You're not alone, but im sure this will be fixed soon. It's not a huge deal since it works 99% of the time anyway.
 

dr_lha

macrumors 68000
Oct 8, 2003
1,587
0
Yes, I noticed this too on web forms. A fix that often seems to work is to press the delete key before typing, if you then see the Shift key highlighted, then from this point the autocorrect seems to work.
 

unity

macrumors 6502a
Sep 30, 2005
926
0
Green Bay, WI
Add me to the list. Rather annoying. I will pay attention to the "delete before typing" thing. I noticed I have to do that to almost any field, that is delete to get it to auto capitalize the first word.
 

ericld

macrumors member
Jul 3, 2007
31
0
Are we sure that the auto-correct isn't off in fields that you may not want corrention in? For example, you want auto-correction in the notepad, but not in the safari URL entry field. Try typing your bank's website with that correction feature enabled. Mine is:

efirstbank.com (like e-firstbank)
 

unity

macrumors 6502a
Sep 30, 2005
926
0
Green Bay, WI
Are we sure that the auto-correct isn't off in fields that you may not want corrention in? For example, you want auto-correction in the notepad, but not in the safari URL entry field. Try typing your bank's website with that correction feature enabled. Mine is:

efirstbank.com (like e-firstbank)
Good idea, but for me it happens or not in the same field. Take these forums for example. I am here more with my iPhone than my Mac. When I start writing a post its hit or miss and I never quote anyone when using my phone - mainly cause I cant scroll in the text field!