Autocorrecting one character

tigerchic6099

macrumors newbie
Original poster
Nov 2, 2016
2
0
Hello! My iPhone has been doing this really annoying autocorrect for some time and I can't get it to stop.... it autocorrects my ampersands (&) to have an additional character after it. For instance, when I type "macaroni & cheese", it autocorrects it to "macaroni &a cheese" or "macaroni &I cheese". I've tried to add in " & " as a shortcut, but it doesn't allow it since it's technically only one character... Has anyone else had this issue and if so, how do I fix it?
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
48,867
17,503
Have you tried resetting your keyboard dictionary (from Settings > General > Reset)?
 

tigerchic6099

macrumors newbie
Original poster
Nov 2, 2016
2
0
Have you tried resetting your keyboard dictionary (from Settings > General > Reset)?
I just reset my keyboard, went to my messages and typed "Macaroni & cheese" and it still wants to correct it to "Macaroni &a cheese". :( Any other ideas?
 

ZZ Bottom

macrumors 6502a
Apr 14, 2010
805
206
My iPhone 6s running latest iOS 10 refuses to let me type "&" without adding an "a" onto it.

OP did you find a solution to this absurd annoyance?

Hello! My iPhone has been doing this really annoying autocorrect for some time and I can't get it to stop.... it autocorrects my ampersands (&) to have an additional character after it. For instance, when I type "macaroni & cheese", it autocorrects it to "macaroni &a cheese" or "macaroni &I cheese". I've tried to add in " & " as a shortcut, but it doesn't allow it since it's technically only one character... Has anyone else had this issue and if so, how do I fix it?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.