Autofill in Wifi login window

Discussion in 'Mac Basics and Help' started by purpleastronaut, Feb 18, 2014.

  1. purpleastronaut macrumors newbie

    Joined:
    Feb 18, 2014
    #1
    When I boot up my MBP, a Safari window with my apartment's WiFi login page opens automatically. It's not a full-blown Safari window, but it seems it's a "feature" for connecting to WiFi networks that require login credentials (similar to some hotels/public networks that require you to pass through a page before you can actually access the Internet). The window has a button in the bottom right corner that says "Cancel" until you log in, at which point it says "Done" and allows you to close the window once the login has occurred.

    Anyways, I am annoyed by the number of times I have to enter in the same info into this window (my network requires it nearly every time I wake my MBP up from sleep; it's a nightmare). If any of you are familiar with this login window, is there a way to set up autofill? I'm not sure where to begin as the window doesn't show a URL or anything so I can't really manually enter it into the autofill settings. Even a setting to disable the window from popping up automatically might be helpful so I could just log in through the browser and more easily setup autofill. If any of you are familiar with this feature, your help would greatly be appreciated.

    BTW, this didn't happen until I upgrade to Mavericks. At first it was handy to make sure I connected to the network first thing when my computer booted up, but now it's popping up constantly and you can't minimize it until you decide either to cancel the network login or fill out the form.
     
  2. Tumbleweed666 macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #2
    I wonder if its something to do with your routers configuration? Have a mosey in there and see what you can find.
     
  3. purpleastronaut thread starter macrumors newbie

    Joined:
    Feb 18, 2014
    #3
    Solved

    After some research, I discovered that the prompt is showing because my Internet connection goes through a Captive Portal. My solution was to disable this feature, allowing me to log in to the network via my browser with autofill username and password. In case anyone else experiences this issue, rename
    Code:
    /System/Library/CoreServices/Captive Network Assistant.app
    to
    Code:
    /System/Library/CoreServices/No More Captive Network Assistant.app
    Hope this helps!
     

Share This Page