Automatic Backups Not Working!

Discussion in 'Mac Basics and Help' started by slinky0390, Sep 20, 2007.

  1. slinky0390 macrumors regular

    Joined:
    Aug 22, 2005
    #1
    hi, currently im using an automator script to copy my home folders contents over to an external hardrive via usb. the hard drive is rarely turned off. the automator script is set as an iCal alarm and set to trigger at 2am on sundays. since my mac sleeping at that time, i set the scheduler wake my mac at 1:50am on sunday. This was working fine for the longest time and everything was ok. well lately, it just hasnt been backing up anything. ive even tried changing the times of the alarm, and itll backup for that first week and not the next ones. (yes the alarm is set to repeat and never end) i searched apples faq's and unchecked the icalalarmscheduler in my startup items hoping ot narrow down why it may not be working. Is there something wrong here, or am i just completley overlooking something.
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Your Mac isn't taking more than 10 minutes to wake up from sleep, is it? Your energy saver settings may also be interfering. Make sure that all the settings are set to something greater than 10 minutes, at least. I recommend setting display sleep to 15 minutes (since that should NOT interfere with your backup script) and computer sleep to at least 1 hour (since that WILL interfere).
     
  3. slinky0390 thread starter macrumors regular

    Joined:
    Aug 22, 2005
    #3
    my mac wakes up almost instantainously, i just have it wake up 10 minutes before just because. my display sleeps at 10 minutes (will it really make a difference if its 15?), and i have it set so it never sleeps my mac. other than that, im stumped.. the hard drive works properly, and if i manually execute the script it backs up.. it seems like the problem is with iCal since the alarm isnt triggering. thanks for your thoughts though
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    Okay, clearly the problem isn't with your energy saver settings. The next thing to test is iCal. Do other iCal alarms work as intended? If they do, then... I'm not sure what's going wrong. If they don't, that suggests that the iCal alarm scheduler isn't running.
     
  5. slinky0390 thread starter macrumors regular

    Joined:
    Aug 22, 2005
    #5
    i dont have any other alarms set, i removed the ical alarm scheduler from my login items, logged out, and then logged back in, so hopefully that restarted it... hopefully that is is, otherwise i guess i just manually do it and wait for time machine (i dont feel like paying for an aditional backup program, but ill buy a new os with a backup program)
     

Share This Page