Automatic Login Disabled OS X Yosemite?

mad3inch1na

macrumors 6502a
Original poster
Oct 21, 2013
662
6
Hi Everyone,

I am interested in not having to sign in with my password on OS X Yosemite when I restart my system. I tried enabling automatic login from the system preferences, but it stays locked even when I enter my password to unlock the settings. Is there something else I am missing?

Matt
 

Cythth

macrumors regular
Feb 24, 2013
107
0
Lake Jackson, TX
Not sure I'm helping with this, but did you turn on FileVault when you upgraded? Maybe that requires a login. Just guessing here....
 

Kwozzii

macrumors newbie
May 24, 2010
25
9
Not sure I'm helping with this, but did you turn on FileVault when you upgraded? Maybe that requires a login. Just guessing here....
Just did as you said ( disabled FileVault) and it did indeed allow automatic login to be selected...

Kwozzii
 

Kaliki

macrumors newbie
May 22, 2008
3
0
What if it doesn't?

I've got Yosemite Beta installed on an external HDD and it's not allowing the Auto Login option...
 

Kaliki

macrumors newbie
May 22, 2008
3
0
Is that a new change since Yosemite? I've had no problem with this in Mavericks...

In fact, I have another computer that has Yosemite Beta 1 on it and it has iCloud syncing keychains and it auto-logs in...
 

diagnostics247

macrumors member
Jul 29, 2012
34
0
I just did a fresh install of Yosemite. My previous install had automatic login working just fine. After the install I can no longer setup automatic login for the admin account. I have tried everything listed in this thread here and several other places as well.

It is very frustrating.

EDIT:

I was able to get automatic login working

1. System Preferences > Users & Groups > Change Password

2. Instead of using your iCloud PW to login - opt to change your password for login in

3. Set your new password

4. Go enable automatic login.
 
Last edited:

antoniofhowe

macrumors newbie
Sep 21, 2014
1
0
I just did a fresh install of Yosemite. My previous install had automatic login working just fine. After the install I can no longer setup automatic login for the admin account. I have tried everything listed in this thread here and several other places as well.

It is very frustrating.

EDIT:

I was able to get automatic login working

1. System Preferences > Users & Groups > Change Password

2. Instead of using your iCloud PW to login - opt to change your password for login in

3. Set your new password

4. Go enable automatic login.
Thank you! Worked like a charm.
 

X-X

macrumors 6502
Aug 22, 2014
401
9
BE AWARE!

If you don't use FileVault your Mac IS NEVER password protected.

Because the password can be reset very easily and it doesn't require anything.

I would think about that on a portable Mac.
 

Muscleflex

macrumors 6502
Jan 26, 2010
312
0
This helped me as well! Thank you very much!

I just did a fresh install of Yosemite. My previous install had automatic login working just fine. After the install I can no longer setup automatic login for the admin account. I have tried everything listed in this thread here and several other places as well.

It is very frustrating.

EDIT:

I was able to get automatic login working

1. System Preferences > Users & Groups > Change Password

2. Instead of using your iCloud PW to login - opt to change your password for login in

3. Set your new password

4. Go enable automatic login.
 

kolax

macrumors G3
Mar 20, 2007
9,181
115
BE AWARE!

If you don't use FileVault your Mac IS NEVER password protected.

Because the password can be reset very easily and it doesn't require anything.

I would think about that on a portable Mac.
Agreed. Automatic login and unencrypted hard drives are a big security concern. iCloud keychain only needs your Mac password to display all your passwords, and your Mac password can easily be changed if someone has physical access to your machine.

Every family member of mine has FileVault or BitLocker (Windows) enabled. The more personal info you have on your computer, the more you really should be practising good security.
 

DonCarlos

macrumors regular
Dec 14, 2009
149
24
Las Vegas
I was able to get automatic login working

1. System Preferences > Users & Groups > Change Password

2. Instead of using your iCloud PW to login - opt to change your password for login in

3. Set your new password

4. Go enable automatic login.
This absolutely works..........and when I set the new password, I used the same as my old password, and it allowed that. So no need to conjure up a new password that gets lost in the shuffle.

Be sure to "unlock" in the lower left corner, before and after doing the above.

Works like a charm........now if I can find a valid solution for the loss of audio control, when sending to a TV via HDMI, then Yosemite would be fully functional.
 

kolax

macrumors G3
Mar 20, 2007
9,181
115
now if I can find a valid solution for the loss of audio control, when sending to a TV via HDMI, then Yosemite would be fully functional.
It's meant to be like that since you're passing a digital signal. You use the amplifier receiving the digital signal (e.g your TV) to control the volume.
 

DonCarlos

macrumors regular
Dec 14, 2009
149
24
Las Vegas
It's meant to be like that since you're passing a digital signal. You use the amplifier receiving the digital signal (e.g your TV) to control the volume.
Thank You, I can deal with that.

I first went back to the internal speaker and adjusted the sound level way down, and then switched the output back to the HDMI category, and am controlling the final output of the volume with the TV remote.

I found that if I didn't adjust the volume output first in the mini's internal speaker, the final volume coming out if the TV was joltingly loud (trying to keep the TV volume fairly balanced regardless of what mode the TV is in).

I considered the matter resolved. Enjoying the mini now that those two pesky issues are resolved.

Thanks again
 

SD-B

macrumors 6502
Apr 1, 2009
399
14
I was able to get automatic login working

1. System Preferences > Users & Groups > Change Password

2. Instead of using your iCloud PW to login - opt to change your password for login in

3. Set your new password

4. Go enable automatic login.




Im on a 27" retina iMac and getting tired of having to log on all the time



Tried this method but all it did, I believe, is change my password.
I will still have to log on.
Is there not a way to turn it off?
 

iluvmangoes

macrumors newbie
Apr 17, 2015
1
0
Hey,

If I turn off FileVault, turn on Automatic Login and then turn on FileVault again, will Automatic Login still work? Need to know as don't feel safe without FileVault but want Automatic Login for alarms in the morning when travelling etc to save battery over night.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.