Automatic Switching WiFi>Ethernet>WiFI>etc.

Discussion in 'Mac OS X Server, Xserve, and Networking' started by McRumour, Jun 2, 2016.

  1. McRumour macrumors member

    Joined:
    Oct 6, 2013
    #1
    What might I be doing wrong?
    I no longer seem to be able to switch back and forth between wired and wireless automatically !


    Setup:
    Router:.................Airport Extreme 6gen v.7.7.7
    NetworkExtender: AE (same model as above)
    Computer: ...........MacBookPro - (OS X 10.11.5)
    Modem: ...............Arris sb 6183

    Situation:
    The Arris Modem is brand new. It's replacing a combo Motorola Router/Modem unit that had been set to bridged mode (router disabled), as I was using the Airport Extreme.

    I rarely use a wired connection for anything.
    With that old modem I'd occasionally test my speeds both wirelessly and then wired at speedtest.net - one test following the other.
    To do so - I'd do nothing other than run some wireless tests, and as soon as they were done - would connect my MacBook to the Airport Extreme router with an ethernet cable.
    Before running the wired test I would NEVER first click on the wi-fi icon on the computer menu bar in order to turn wi-fi off.
    Nor would I open System Preferences to change Network Settings from Wi-Fi to Ethernet. The "Location" (in Network) was set to "Automatic"
    I just ran the tests, got the results.....and once completed, unplugged the ethernet cable at both ends...and voilá.... was back on to Wi-Fi

    Meanwhile, in Airport Utility - the green dots beside the 2 AE icons would turn to amber when I was no longer wireless - and then back to green when I disconnected the ethernet cable from the computer

    Now, with the new Arris modem, I'm unable to switch seamlessly, back and forth
    Once I've run the wired speed tests and then disconnected the cable - I'm no longer online. Nor am I able to get back online.
    Clicking on the menu bar icon - to put a check beside my network name - doesn't solve the problem, nor does closing and re-opening Airport Utility, nor does closing and re-opening my browser. I have to jump thru hoops to get "back to normal" eg Shut Down computer altogether! And re-boot.

    Don't know whether the modem is the issue or the firmware updates on the 2 AEs - which, coincidentally, installed just as I was setting up the new modem (24 May) - or whether it's something I'm doing (or failing to do)?

    Bottom line - what exactly SHOULD I be doing to seamlessly switch from wireless to wired and then back to wireless....just as I've described I'd always done previously?
     
  2. AppleNewton macrumors 68000

    AppleNewton

    Joined:
    Apr 3, 2007
    Location:
    1 Finite Place
    #2
    If you're talking about your Mac connecting automatically to wired or wireless... Then you want to set the service order in network preferences in System preferences,mane have wired or Ethernet listed first then wifi and select set service order...that should allow the Mac auto switch when connected..but not sure if that's what you're trying to accomplish or if you're trying to change another router to do automatic switching which I don't think is possible.
     
  3. McRumour thread starter macrumors member

    Joined:
    Oct 6, 2013
    #3
    Hi....thanks for your reply

    Just saw your post - after finally having already sorted the issue - but you're dead right!
    It turns out that the "set service order" was incorrect
    I did have to do exactly what you advised - and now all's perfectly perfect

    ps (love your user name btw) ;-)
     

Share This Page