Automatic Time Zone Incorrect

Discussion in 'macOS' started by c6viperkiller, Jun 20, 2010.

  1. c6viperkiller macrumors newbie

    c6viperkiller

    Joined:
    Jul 24, 2005
    Location:
    Seattle, WA
    #1
    I recently moved from Illinois to Ohio. Now, when I go to either google maps or the time zone settings on my Macbook Pro, it thinks I am in Illinois. Google maps will update eventually to the correct location, however the the time zone in OS X will not.

    I have tried deleting .plist files and rebooting, but neither has fixed the problem. Anyone have any suggestions?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
  3. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #3
    Change the time zone manually in System Preferences -> Date and Time...
     
  4. c6viperkiller thread starter macrumors newbie

    c6viperkiller

    Joined:
    Jul 24, 2005
    Location:
    Seattle, WA
    #4
    I realize I can do it manually. But I would like to have the automatic feature work as advertised.
     
  5. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #5
    Restart your machine and see if it works then. Or just take the 15 seconds to fix your problem straight away.
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    The automatic feature depends on you first selecting your time zone from System Preferences. Once you do that, it will adjust everything else accordingly. It's a computer, not a mind-reader.
     
  7. VideoFreek macrumors 6502

    VideoFreek

    Joined:
    May 12, 2007
    Location:
    Philly
    #7
    I assume that 1) you are using Snow Leopard and 2) you realize that you must have wireless networking turned on, for this is how the Mac determines your location, using "fake GPS." You can follow the steps here to make sure you're doing everything correctly.
     
  8. c6viperkiller thread starter macrumors newbie

    c6viperkiller

    Joined:
    Jul 24, 2005
    Location:
    Seattle, WA
    #8
    VideoFreek, I am using Snow Leopard and have WiFi turned on. I looked at the site you referenced and I have followed the steps exactly, yet my computer still thinks I am in Illinois. I am in Ohio.
     
  9. mikes63737 macrumors 65816

    Joined:
    Jul 26, 2005
    #9
    If you moved your router with you from Illinois, try unplugging your router and having it update the time zone. If this works, it means that your router has been recorded by whatever services Apple uses to determine this location as being in Illinois.
     
  10. VideoFreek macrumors 6502

    VideoFreek

    Joined:
    May 12, 2007
    Location:
    Philly
    #10
    Hmm...looks like others are having the same problem here. It may be a bug in SL. Try verifying that geolocation is working at your location using Google maps or something. If not, <see below>. Try trashing the plist file mentioned in the link, if you haven't already. Other than that, I'm afraid I'm out of ideas.

    EDIT: one other idea... CoreLocation services in Snow Leopard uses the Skyhook worldwide database of wireless access points to pinpoint your location. If you've moved with your wireless router, Skyhook may simply think you're still at your old location because they haven't rescanned your new area yet. The fact that you mention that Google maps starts off at your old location and then eventually gets it right suggests that there is something funky going on with the geolocation database. Skyhook uses the broadcast MAC addresses of nearby wireless routers, so you'll need to manually update your router's location on Skyhook's website.
     

Share This Page