Automator - Scale Images hangs in Lion

Discussion in 'Mac OS X Lion (10.7)' started by chockymonster, Aug 17, 2011.

  1. chockymonster macrumors member

    Joined:
    Jul 9, 2008
    #1
    Since updating to Lion the Automator workflows I've created to resize images have stopped working properly and I can't figure out why.

    It's a simplish workflow that works on folder input, gets the folder content and uses an applescript to copy the files to a different folder in the parent folder.

    It then changes to the folder, gets the folder contents and runs the scale images to a given pixel size.

    Everything used to run fine until the Lion upgrade, now I find that it always stops at a point during the scale actions which seems to be at the 174th image.
    I've tried renaming/moving images around to see if it's a problem with an image but that hasn't helped.

    Can anyone suggest any other troubleshooting steps?
     
  2. res1233, Aug 17, 2011
    Last edited: Aug 17, 2011

    res1233 macrumors 65816

    res1233

    Joined:
    Dec 8, 2008
    Location:
    Brooklyn, NY
    #2
    Could we (I) take a look at your workflow?

    EDIT: Why do these threads always seem to die early? I swear, OPs for threads of this nature seem to vanish the moment the thread has been made. Sucks because I love anything Automator/AppleScript related.
     
  3. chockymonster thread starter macrumors member

    Joined:
    Jul 9, 2008
    #3
    Gimme a chance!

    Here's the workflow, it's possibly not the cleanest way to do it but I couldn't figure out another way.
    I'd just like it to work again!
     

    Attached Files:

  4. dmarkow macrumors newbie

    Joined:
    Dec 7, 2011
    #4
    I'm having the exact same issue on Lion. I manually drag a couple thousand JPG files into automator and add the Scale Images action to scale everything down to 1024 pixels. When I run it, it processes exactly 175 images and then hangs. I have to stop it and re-run it multiple times to resize everything. Did you ever figure out a solution to this?
     

Share This Page