automator services not working in 10.6.2

Discussion in 'macOS' started by jpma, Nov 10, 2009.

  1. jpma macrumors 6502

    Joined:
    May 31, 2009
    #1
    right after 10.6.2 installed,
    all the automator shortcuts in the keyboard system preference went missing.
    even creating a new service from automator also doesn't work anymore.

    I can open automator just fine, but the service or workflow I created just doesn't work anymore.

    anyone else having this problem?
     
  2. jpma thread starter macrumors 6502

    Joined:
    May 31, 2009
    #2
    nobody?

    if you don't have this problem at least notify me.
    So I won't sit here wondering what's going on around
     
  3. moeboyd macrumors newbie

    Joined:
    Nov 16, 2009
    #3
    yup, something in automator is wrong..

    I am also having problems with automator actions that worked fine in 10.5 break in 10.6. I've tried re-recording to no avail. The Watch Me Do script breaks repeatedly, there is also a post on the Apple discussion forums...
     
  4. SkeffMBP macrumors member

    Joined:
    Oct 21, 2008
    #4
    I'm now in the same boat - I can't get any automator actions to work properly
     
  5. dambo29 macrumors newbie

    Joined:
    Nov 28, 2009
    #5
    Also having problems!

    I had some really kick ass Automator services setup that used to work great in 10.6.1 but now in 10.6.2 they don't even show up and when I go up top to the menu and click on services it just says "Building..." in any app I'm in.:mad:

    Has anyone found out how to get this working again?
     
  6. jpma thread starter macrumors 6502

    Joined:
    May 31, 2009
    #6
    did any of your use software like clean my mac or anything that remove language or ppc universal software ?

    I'm thinking that might be the cause.
     
  7. dambo29 macrumors newbie

    Joined:
    Nov 28, 2009
    #7
    Fixed!

    After much work I found the solution to the problem.

    Go to:
    (Username)>Library>Preferences

    Delete the following:

    com.apple.Automator.plist
    com.apple.Automator.LSSharedFileList.plist

    After that, Services should be back and running. At least they are for me!

    :D
     

Share This Page