Automator steps repeating under Yosemite

Discussion in 'OS X Yosemite (10.10)' started by BlueChroma, Dec 15, 2014.

  1. BlueChroma macrumors newbie

    BlueChroma

    Joined:
    Nov 22, 2004
    Location:
    New Jersey
    #1
    I have a folder action that renames iTunes receipts with a new name and the current date. Under Mavericks it ran fine, but now in Yosemite the last step continues to repeat itself. When I save the email of the receipt as a PDF with the default name that pops up of "Your receipt No. 123456" to my "Receipts" folder. The folder action then changes "Your" to 'iTunes' and then adds then current date to the front of that. But now when the date is added it repeats it over and over. So instead of "2014-12-15 iTunes Receipt No.123456" I get "2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 2014-12-15 iTunes Receipt No.123456"
    Anyone else having a problem with automator since Yosemite? Is my folder action set up right? It's not set on loop or anything like that. I'd appreciate any input, thanks.

    Here is my action:
     

    Attached Files:

  2. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #2
    I would try removing that last action, saving the file as a new one, then re-adding that last step?
     
  3. BlueChroma thread starter macrumors newbie

    BlueChroma

    Joined:
    Nov 22, 2004
    Location:
    New Jersey
    #3
    I tried that twice and even started over from the beginning, but I'm still getting the date repeated.
    Thanks for replying
     
  4. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #4
    Is it only that action that gets repeated or does it repeat the last action in the sequence, whatever that is?
     
  5. BlueChroma thread starter macrumors newbie

    BlueChroma

    Joined:
    Nov 22, 2004
    Location:
    New Jersey
    #5
    If I remove the last step or replace it with something else, things work fine. Its just the date that is stuck in some kind of loop.
     

Share This Page