Automator - to open automatically some file extensions

Discussion in 'OS X Yosemite (10.10)' started by myname70, Sep 26, 2014.

  1. myname70 macrumors 6502a

    Joined:
    May 5, 2014
    #1
    Hi Guys, I try to set as soon as download .torrent file in Downloads, the transmission to open it automatically. I set an Automator rule (see attached pic), but the problem is that it tries to open ALL files i add in Downloads, not only .torrent extension. Any idea how to make it? Thanks
     

    Attached Files:

  2. kryten2, Sep 30, 2014
    Last edited: Sep 30, 2014

    kryten2 macrumors 6502a

    Joined:
    Mar 17, 2012
    Location:
    Belgium
    #2

    Replace the Find Finder items action with a Filter Finder items action. A good Folder Action leaves the hot folder empty. This avoids repeated application of the action to the same files, and allows Folder Actions to perform more efficiently
     

    Attached Files:

  3. myname70 thread starter macrumors 6502a

    Joined:
    May 5, 2014
    #3
    thanks! I did Filter Finder as advised. But it again start open ALL files (does not matter the extension is not .torrent) by the Transmission app.... Obviously it does not recognise / filter the extensions
     
  4. kryten2, Sep 30, 2014
    Last edited: Sep 30, 2014

    kryten2 macrumors 6502a

    Joined:
    Mar 17, 2012
    Location:
    Belgium
    #4
    Put a Get Specified Finder items action at the top and add 2 files to it e.g. a torrent file and something else , then run the workflow manually by clicking the play button. Look at the results of Filter Finder items action. You should only see the torrent file. Filter Finder items has been buggy in the past as well. I'll do some testing myself a little later in the evening. Right now I'm kinda busy.

    What version of Yosemite are you running? Did you upgrade to GM Candidate to see if it makes any difference?

    Edit : Just did a quick test on Mavericks with a Get Specified Finder items and a Filter Finder items action. See the screenshot.
     

    Attached Files:

  5. myname70 thread starter macrumors 6502a

    Joined:
    May 5, 2014
    #5
    I updated now to GM1 but the same result. . If I run the workflow manually it opens the torrents files only. But if add some files in download folder -it tries to open all of them. (Not only torrents ). If I add Get specified folder items - how can filter them for file extensions? Or to add inside the download folder ?
     
  6. phrozend macrumors member

    Joined:
    May 14, 2014
    #6
    Unless I'm missing something here, you can actually do this without Automator.

    The Transmission-app actually got an option for this.

    Preferences -> Transfers -> Auto add

    It will automatically hunt for .torrent-files saved in a specific folder.
     
  7. kryten2 macrumors 6502a

    Joined:
    Mar 17, 2012
    Location:
    Belgium
    #7
    Thanks for the tip phrozend. I don't have/use Transmission but if that is possible then it is a good alternative for myname70 to use.
     
  8. myname70 thread starter macrumors 6502a

    Joined:
    May 5, 2014
    #8
    Thank you Guys! I did not know about this option in the Transmission :) Now it is activated and works fine. The Automator actions/training was useful as well (in general, for another extensions )
     

Share This Page