Automount network drive when running App. How do I stop it?

Discussion in 'macOS' started by bugfaceuk, May 7, 2007.

  1. bugfaceuk macrumors 6502

    bugfaceuk

    Joined:
    Nov 10, 2005
    #1
    You know, there are times I'd love to do this. Basically I have an application (parallels) that automounts the fileserver (afp) on my home network when I run it. Cool. Unless I'm not on my home network when parallels has to sit there bounching for 10 minutes waiting to hear back from OS-X that it can't mount the drive.

    So, I uninstall Parallels. Re-install. Start new Parallels. It mounts the flippin drive.

    So in my ignorance I am assuming OS-X is doing it. How do I stop it? I've nuked the preferences files for Parallels. No change. It's not using a file on that drive, and as far as I know never has. Why oh Why?

    And how did I set up this association between an application and mounting something? It would be a good trick if I knew what I'd done!

    Thanks in advance folks. :confused:
     
  2. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
  3. bugfaceuk thread starter macrumors 6502

    bugfaceuk

    Joined:
    Nov 10, 2005
    #3
    Thank you so much for pointing that out, I was very excited for a while as that's exactly my problem. However, for me deleting the file did nothing.

    I'll do a tour of the OS looking any other little file it might be hiding... any other hints very gratefully accepted.

    Thanks again, that really sounded exactly the problem.
     
  4. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #4
    You also deleted all the preferences (and pref folders) associated with Parallels?
     
  5. bugfaceuk thread starter macrumors 6502

    bugfaceuk

    Joined:
    Nov 10, 2005
    #5
    Yes I had, but I have infact solved it (at last!).

    Finally gave up with looking myself and hit the shell, and found this folder:

    /Users/<<username>>/Documents/.parallels-vm-directory/

    Which has links to files on different drives including I presume a single miss clicked and ran a VM from my network backup drive at some point, and the soft-link was causing the auto-mount.

    Thanks for you help, and I hope this helps someone else at some point.
     

Share This Page