Automounting AFP Share Points

Discussion in 'Mac OS X Server, Xserve, and Networking' started by iceman575, Jun 30, 2011.

  1. iceman575 macrumors newbie

    Jan 31, 2009
    I am administering an OSX 10.6 Server using the Magic Triangle between AD and OD. I have both directories configured and my test client bound to both directories (with significant help from Mactasia). I am now attempting to set up automount network shares.

    I have been able to create a Test Account whose home folder is set to a network drive and that is configured correctly. The drive hosting the home folder automounts on each log in. I have tried the same procedure with two entire RAID partitions that I would like to use as automounts, but the best I can manage is that on login I open finder, select my server (which shows it is connected and authenticated) and then select the RAID partition. It mounts immediately. On the client, when I add the manually mounted partition to the sidebar, dock, or desktop it refuses to automount on the next login. Using Server Admin I have created the Automount record and have set permissions, but I cant seem to get it to automount.

    Any thoughts?
  2. Mactasia macrumors member


    Jun 10, 2011
    This is how I setup my auto mounts.

    Login on to a client machine with Server Admin tools installed. Map your drive you want to automount, via Go > Go to Server. Once mapped it should appear on the desktop (if not, Finder > Preferences > Check Connected Servers).

    Open WGM and authenticate to the LDAP directory. I presume you will be managing this by Computer Group? (you could also do it by User groups). If so, select the computer group, and go to the Preferences tab. Select Login and then the Items tab.

    You should be able to drag the mapped drive from the Desktop in to this window. Highlight and select the relevant options (for example, authenticate selected share point with user's login name and password.

    Hope this helps ;)
  3. iceman575 thread starter macrumors newbie

    Jan 31, 2009
    Mactasia, you are brilliant! That worked first try no problems. Thanks!

Share This Page