Resolved Avast install fails when validating packages

Discussion in 'OS X El Capitan (10.11)' started by house13um, Aug 9, 2015.

  1. house13um macrumors newbie

    Joined:
    Aug 9, 2015
    #1
    Haven't been able to find this issue elsewhere, except during the earlier variants of the developers beta.

    Have a 2012 i5 Mac Mini with a 120gb SSD and 500gb HDD using the iFixit kit. I've been running the public beta since release on the SSD (wherein Avast had been working fine), but yesterday I installed the dual HD setup, did a fresh install of Yosemite on the SSD, then updated back to 15A243d public beta and installed Windows 8.1 on a Bootcamp partition on the SSD, leaving the HDD with one Mac OS Journaled partition and one NTFS partition. Both El Capitan and Windows 8.1 see all drives and partitions just fine.

    Beforehand, when Avast worked, I had installed it originally on Yosemite, and the app had rolled over through the El Capitan updates. This time, however, I tried to install it after I updated to 15A243d – no go. Fails each time it tries to validate the packages after running package scripts, right near the end of the install. Also, unlike on Yosemite, it won't let me choose whether I want to install on a specific disk or for a specific user; it forces me to choose to install for all users of the Mac.

    Anyone know what might be at fault here?
     
  2. tills24 macrumors member

    Joined:
    May 10, 2010
    #2
    I had the same thing happen when installing both Avast and Symantec Endpoint Protection. Sadly, I cannot provide an answer, only bumping.
     
  3. house13um thread starter macrumors newbie

    Joined:
    Aug 9, 2015
    #3
    Problem resolved.

    Had to disable System Integrity Protection (SIP) from the Recovery partition. Terminal -> "csrutil status" -> Was enabled, so used "csrutil disable", then rebooted. Installation went fine. Went back and used "csrutil enable" to switch it back on.
     
  4. tills24 macrumors member

    Joined:
    May 10, 2010
    #4
    Awesome, that worked for me, too. Thanks for the heads up!
     
  5. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #5
    You can just use the security configuration tool from the utilities menu in the recovery system. No need for Terminal.
     

Share This Page