AVCHD folders showing as a Package

Discussion in 'OS X Mountain Lion (10.8)' started by labtopia, Jul 18, 2012.

  1. labtopia macrumors newbie

    Jul 18, 2012
    has anyone got an idea of how to keep the new finder from showing folders with avchd content as packages?

    i just want finder to show folders as folders. this seems to be really dumb thing they've done and i cannot seem to find a preference somewhere.
  2. timothevs macrumors 6502


    Nov 17, 2007
    I am sorry, I don't have an answer to this, but WOW am amazed at how well my MTS files play with QuickTime without the need of any codecs. In fact iPhoto can play the movies natively! I have waited for this so long.
  3. labtopia thread starter macrumors newbie

    Jul 18, 2012
    yeah but this is a nightmare for data management- on a file level why in gods name would want an os to do this?

    i have defaultapp app and have dissabled the com.avchd, waiting for a download to finish to reboot and see if this fixes this problem.
  4. iThinkergoiMac macrumors 68030

    Jan 20, 2010
    You can always just right-click (ctrl-click/two finger click) and choose "Show Package Contents..."
  5. labtopia thread starter macrumors newbie

    Jul 18, 2012
    that's not really an option, i need to browse folders and files in the file system as folders and files. interestingly the same files on an NTFS partition are handled correctly and dont show this bundleing.
  6. iThinkergoiMac macrumors 68030

    Jan 20, 2010
    OK... what DOES happen when you double-click it?
  7. labtopia thread starter macrumors newbie

    Jul 18, 2012
    they have it set to open in QT player, not very usefull for a content creator. i've tried to use defaultapp.app to disable the com.avchd plist (which is set to QT default) but that doesnt do it.

    i'm hoping when this releases next week, this will be in the flood of issues and an answer to fix will pop up.
  8. iThinkergoiMac macrumors 68030

    Jan 20, 2010
    What do you edit with? Final Cut and iMovie both convert the files first (or SHOULD, if you're using FCPX, I think it'll edit AVCHD natively, but that's slow) so having the file structure doesn't seem to be relevant. Are you using Premiere?

    Without trying to critique whatever setup you have too much, editing native AVCHD is pretty slow, so you should ideally be transcoding to an intermediate format before editing, which would mean you'd be setting up your own file structure anyway.
  9. TomLenham Guest

    This is crazy - there has to be a way to disable it! I'm working professionally on Avid, and I can no longer import any footage at all!


  10. Small White Car macrumors G4

    Small White Car

    Aug 29, 2006
    Washington DC
    Ok, so what happens if you 'show package contents' and just drag the videos to another folder?
  11. vladster macrumors member

    Jul 25, 2011
    Install alternate file browser, like muCommander and browse it just like a directory.
  12. KleinesLicht macrumors newbie

    Sep 6, 2012
    Temporary solution


    I had the same problem, my temporary solution was to rename the folders with the "mucommander" from "AVCHD" and "BDMV" to "AVCHDD" and "BDMVV". After that I was able to watch the .mts files again with the finder. :D

  13. Blashyrkh2124 macrumors newbie

    Oct 9, 2009
    I'd like to get this forum active again as there still doesn't seem to be a solution and this is irritating as hell!

    Isn't there a sudo command or anything? =P
  14. selsyn, Sep 20, 2012
    Last edited: Sep 20, 2012

    selsyn macrumors newbie

    Sep 20, 2012
    Applescript and a video

    Hey all,

    Someone on the Appleboards wrote an apple script to access your AVCHD files.

    After running it, you may then drag/drop (move) the files to the parent folder, (that you are able to access, where the in-accessible PRIVATE and AVCHD [QT 'package' files] live.)

    I did a silent video of a working example here:

    It was in response to another guy that said Apple's position on this is "Use iMovie to import your AVCHD's"! Really... or are they kidding... I do like the fact they are *finally* implementing AVCHD in QT, but iMovie imports take *forever*!

    I'm a professional media maker on Avid/Mac and I can't believe this is Apple's stance. I need to access the AVCHD files *I* created in *my* camera!

    I'm pouring over all the .com and .plist files in Mountain to see if I can change this behavior internally. No luck as of yet.

  15. dcorban macrumors 6502a


    Oct 29, 2007
    The idea is that no one would work directly with the MTS files since they need to be transcoded. Also, for playback, the entire package is usually required. The package format ensures everything is there for proper playback and importing into apps.

    Did anyone explain why the "show package contents", then dragging files out does not work?
  16. selsyn macrumors newbie

    Sep 20, 2012
    I see, so we can't use the transcoder of *our* choice, it has to be yours... hmm.

    I've got a few hundred daily directories, and several hundred more camera roll numbered directories inside those. All stored on a master raw-footage drive. I can't be bothered with renaming folders, show package contents, or working with iMovie. This script involved less clicks.

    I guess you never heard of Avid's ability to AMA Link via a plugin to preview avchd content in our NLE *before* a transcode.

    It's too bad I'm locked out of accessing my folder structure on the card. At the very least give us the option to disable such a big-brother ownership of all that is AVCHD.

    I just hope Apple will do the right thing here.

    thanks for your input,
  17. labtopia thread starter macrumors newbie

    Jul 18, 2012
    yeah, still apple doesnt seem to care about anything but forcing users to use their OS the way they think they should.

    i'll try the muCommander and the applescript and see if this introduces too many steps to get to the files, we are a professional post facility and unnecessary steps hamper productive workflow.

    this issue is what is preventing me from upgrading all of my editorial systems still.

    thanks for the comments to my original post.

  18. ganpati23 macrumors newbie

    Apr 4, 2014
    You could have just used VLC to do that.

    The point the OP was trying to make is that those of us trying to edit from a huge batch of dumps, can't simply see all the various "Private" folders opened so we can check each clip, we have to manually open the packages within packages for each dump.

    When have a few dozen folders all of which contain 023.MTS and it takes ages to get to each one.

Share This Page

17 July 18, 2012