AVCHD to DVD quality loss

Discussion in 'Digital Video' started by Peter JG, Jun 25, 2009.

  1. Peter JG macrumors newbie

    Joined:
    Jun 25, 2009
    #1
    Let me first apologise, I know this is probably a tiresome question but I have been searching the web and can't really determine a solution to this problem. Burned DVD's I create using idvd appear grainy. I have a sony hdr-sr7 avchd camera, editing in FCE, creating a QT movie and then compiling in idvd before burning to disc. Has anyone else had a similar experience and can you please tell me the best settings for each of these stages?
     
  2. Dale Campbell macrumors member

    Joined:
    Mar 29, 2009
    #2
    I have recently been trying to solve a very similar problem.

    Only difference is I have a sanyo xacti which creates mp4 rather than AVCHD files.
    But I think we can rule this out as a cause of any poor quality.

    As far as I could figure iDVD does not create DVDs of what I would call dvd quality.

    Heres the solution I came up with, It has a few steps and requires roxio toast but produces pristine images.

    First export out to iDVD

    then ignore any menus etc as they will not be used in the end.

    go to file and save as a disc image

    once thats done 'open' (mount) the disc image you just made (just double click it)

    now open up toast

    go to video

    Then
    open a finder window and the disc image you open before should be there click on it and you will see 2 folders open the VIDEO_TS folder. Find the file called vts_01_1.VOB ---- (there will probably be 2 .VOB files one is for the menus made in imovie the other is your video content you be able to tell which is which in the next step if you unsure use both for now)

    drag this file into toast it should appear with a little preview picture so you can tell its the correct one.

    Now add some nice simple toast menus!

    Now go to options and select 'encoding' then select custom

    Put all the sliders to full (9mbps)

    IMPORTANT - re-encoding should be set to NEVER!

    rest can be left as is.

    Then burn you disc and hopefully you will have superb quality and no tacky menus eating loads of disc space.
     
  3. WinterMute Moderator emeritus

    WinterMute

    Joined:
    Jan 19, 2003
    Location:
    London, England
    #3
    Which codec are you using when you create the QT movie?

    Have you got iDVD set to it's High Quality setting in preferences?

    The conversion from FCP to QT may be the issue, but you may simply have iDVD set to it;s 2 hour function, rather than the 1 hour hiQ setting.
     
  4. Dale Campbell macrumors member

    Joined:
    Mar 29, 2009
    #4
    Lol for some reason I read imovie somewhere, in which case your workflow is the same as mine.
    I export as a QT movie, (I usually go self contained but no real reason to I suppose).

    Then I drag that into imovie and send it to idvd from there (seems to prefer it in the numerous tests I did). The steps from there are the same as above.
     
  5. Peter JG thread starter macrumors newbie

    Joined:
    Jun 25, 2009
    #5
    Thanks for your help. To answer some of your questions.

    I am using AIC 1440x1080 50i in FCE, exporting using quick time movie not quick time conversion and am using professional setting in IDVD.

    By the way, I've read that a lot of people prefer Toast to IDVD,why is that a better tool?
     
  6. theBB macrumors 68020

    theBB

    Joined:
    Jan 3, 2006
    #6
    I agree with WinterMute. High Quality setting in iDVD is the critical one if any one setting is going to make any difference. High Performance is the misleading one, don't use that one unless you are pressed for time and need the render to finish quickly.

    In any case, iDVD probably does not use a professional grade compression algorithm. It would probably take even longer to render a DVD on consumer computers. It already takes a few hours to get one to render on my 3.5 year old iMac. It might even cost Apple more to license a better algorithm. I doubt Toast would do better, but I'd defer to somebody who actually went through a comparison for creating a DVD from the same movie by using both programs.
     
  7. xStep macrumors 68000

    Joined:
    Jan 28, 2003
    Location:
    Less lost in L.A.
    #7
    I'm confused. Is the AIC file the type you are editing, or is that what you are exporting? What you export will matter.
     
  8. steve123 macrumors regular

    Joined:
    Aug 26, 2007
    #8
    I think I understand your workflow. Unfortunately, the professional setting on iDVD is not quite professional grade. It does give you a good compression and minimizes the compression artifacts. However, where iDVD fails is in the frame conversion between your HD source and SD output. You need to convert from HD with an upper field dominance to SD with a lower field dominance. iDVD isn't very good at this conversion and thus the quality can take a big hit because of the difference in the way the frames are interlaced. Particularly on edges in the video you see all manner of staircase artifacts. MPEGStreamClip can help with this problem as it has a better algorithm than iDVD to do the frame conversion. Take the AIC format into MPEGStreamClip and output a SD DV format. Make sure you select the better 2D FIR filter. Then take the SD DV into iDVD.

    So far, the only solution I've identified that works well has been to use Apple's Compressor application that comes with Final Cut Studio.

    Steve
     
  9. Courtaj macrumors 6502a

    Courtaj

    Joined:
    Jul 3, 2008
    Location:
    Edinburgh, U.K.
    #9
    How long are your movies?

    For movies of only a few minutes, you'll get excellent results by exporting using H.264 as your codec at full resolution, making sure not to deinterlace, and then, after adding / dragging the QT file into iDVD, allowing iDVD to do the down-scaling as it renders.

    This is what I do, and I've always been impressed by the quality.
     
  10. Heb1228 macrumors 68020

    Heb1228

    Joined:
    Feb 3, 2004
    Location:
    Virginia Beach, VA
    #10
    Don't export to H.264 or any other compressed format. You're just adding steps and degrading video quality. Use command, shift, I in iDVD and use professional quality encoding. That's the first place to start.

    Edit: didn't see you already had that checked. Sounds like steve123 may be onto something with interlacing incompatibility to me.
     
  11. bearcatrp macrumors 68000

    Joined:
    Sep 24, 2008
    Location:
    Boon Docks USA
    #11
    Part of it is your camcorder, part of it is the software. Are your settings in the camcorder set to the highest quality? The camcorder has its limits so you have to shoot within its limits. I have the SR11 (AVCHD like yours) and get some graininess too. I find when I zoom out all the way, I get allot more than when retracted. Lighting is also a culprit.
     
  12. bearcatrp macrumors 68000

    Joined:
    Sep 24, 2008
    Location:
    Boon Docks USA
    #12
    Also, shooting around florecent lights really screws with video quality.
     

Share This Page