AVI files in browsers don't play (QT logo with question mark)

Discussion in 'Mac Apps and Mac App Store' started by jollino, Nov 15, 2006.

  1. jollino macrumors 6502


    Nov 15, 2006
    Chieti, Italy
    Hello all,
    I'm encountering a weird problem.

    I don't know when it began, but I cannot play .avi videos (containing ANY codec) in any browser anymore.
    In Safari I get a faded QuickTime logo with a question mark on top, and in Camino or Firefox I get a QuickTime logo without anything, as if it were still loading.
    Camino/FF also say "video/x-msvideo Object" in the title bar, and calling about:plugin shows that that MIME type is (supposedly) taken care of by the QuickTime plugin.

    Opening the .avi files through QuickTime Player works perfectly, and dragging them onto Safari's icon (whilst pressing command and option to "force" it to open it), it works. On Camino this doesn't happen, but neither browser opens them through the network, not even putting the video on the local webserver and using http://localhost/blah.avi.

    I've installed Perian, 3ivX and DivX. I manually uninstalled DivX (especially the QT components and the plugin) and 3ivX using the latter's uninstaller. Perian, anyway, should be enough.
    In fact, I also dragged Perian.component out of /Library/Quicktime, and both browsers DID show the QuickTime progress bar but did not play
    anything, neither audio nor video. QuickTime Player did the same.
    Putting Perian.component back into the QuickTime folder, the files play again in QT Player, but not in the browsers.

    As I said, this happens ONLY with .avi files. Any other video format, including .wmv, works perfectly.

    Just for the sake of it, I created a brand new additional user and tried it: .avi videos don't play in broser for the new user either.
    I also downloaded and reinstalled QuickTime, and checked the MIME type settings in the QuickTime pane in System Preferences, resetting them to the default. Still no luck whatsoever.

    I'm running OS X 10.4.8 (with QuickTime 7.1.3) on an iMac Core 2 Duo.

    Could someone suggest me how to fix this problem? I've already googled up, but although other people have mentioned a similar problem (although never related to a single file type), I haven't been unable to track the issue down.

    Thank you in advance
  2. a.paul macrumors newbie

    Oct 26, 2006
    Anyone? This just started on my new iMac 24"...Right now at the top and bottom of this page there's the stupid "Q" with a question mark in it. I tried to open Safari in Rosetta mode, thinking that Shockwave wasn't a universal app, but that didn't make any difference.
  3. MacsRgr8 macrumors 604


    Sep 8, 2002
    The Netherlands
    Hope I can help you.... are your sure the QuickTime plugins are located in the Internet Plug-Ins directory?

    Here's mine:

    Attached Files:

Share This Page