.AVI files not showing video, only audio

Discussion in 'Mac Basics and Help' started by mushir, Jul 29, 2009.

  1. mushir macrumors newbie

    Joined:
    May 5, 2008
    #1
    I have a few .AVI files that I want to play on my Macbook. But when I play them with Quicktime, it shows me a black screen and plays with only audio. No video. And yes I have installed Perian but that's not fixing this problem either. I tried using VLC but that didn't even show me a black screen. I could only listen to the audio.

    Do I have to install some codecs? If os please tell me step by step on how to do so. Cause I have no idea on how to manually do it.
     
  2. geoffreak macrumors 68020

    geoffreak

    Joined:
    Feb 8, 2008
    #2
    Try using MPlayer OSX instead. If you don't have any video there, the file is corrupt.
     
  3. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #3
    If VLC can't play it, then the file is possibly corrupt. Don't even bother with QT for .avi files.
     
  4. geoffreak macrumors 68020

    geoffreak

    Joined:
    Feb 8, 2008
    #4
    VLC is crap (QT is even more so). Don't use it as a basis of if a file is corrupt.
     
  5. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #5
    VLC is the greatest movie player app ever!
     
  6. geoffreak macrumors 68020

    geoffreak

    Joined:
    Feb 8, 2008
    #6
    Wrong. The greatest movie player app ever is Plex.
     
  7. surflordca macrumors 6502a

    surflordca

    Joined:
    Nov 16, 2007
    Location:
    Ontario, Canada
    #7
    VLC has played everything I through at it :)
     

Share This Page