AVI to IDVD no sound..... Why?

Discussion in 'Digital Video' started by MikeT125, Feb 8, 2010.

  1. MikeT125 macrumors regular

    Joined:
    May 16, 2007
    #1
    I have an AVI file that has sound on it. I imported it into iDVD so that I could put it on a DVD and play it on my DVD player. It looks perfect but there is no sound. When I play the AVI on my iMac using VLC player there is sound but the final product out of iDVD does not have sound. Is there a setting I am missing???
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    .avi is only a container for lots of codecs, for video and audio. Maybe iDVD is not able to read the audio because of the codec, as iDVD does not use the same libraries to read video and audio as VLC Player does.

    You could try to use MPEG Streamclip to convert the .avi file to a DV file, thus the audio and video will be recognized by iDVD and can be properly burnt to DVD.

    But try to pay the .avi file first in MPEG Streamclip, to check if the audio is recognized. If not, maybe install Perian.
     
  3. MikeT125 thread starter macrumors regular

    Joined:
    May 16, 2007
    #3
    MPEG streamclip does not play any sound either.....
     
  4. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #4
    Then download Movist, open the .avi there, press CMD+OPTION/ALT+C, select Properties and tell us what it says there.
     

Share This Page