AW Series 4 Won't Charge

Mikeeee

macrumors 6502
Original poster
Sep 27, 2017
396
245
I'm sure this is very rare but I picked up a SBSS today that won't charge. I did get it to charge a few percentage points but then it literally started discharging instead of charging.

I did a hard reboot, re-paired with a fresh install and checked the charger with my Series 3. The charger was fine. Unfortunately it seems I have this defect. Wondering if any others experienced this or if there is another step I might be missing in trouble shooting before I pack it up and return it.
 

redavis41

macrumors member
Sep 14, 2017
96
43
I'm sure this is very rare but I picked up a SBSS today that won't charge. I did get it to charge a few percentage points but then it literally started discharging instead of charging.

I did a hard reboot, re-paired with a fresh install and checked the charger with my Series 3. The charger was fine. Unfortunately it seems I have this defect. Wondering if any others experienced this or if there is another step I might be missing in trouble shooting before I pack it up and return it.
Try another charger if you can. I had this same issue. Sometimes it would charge quickly and other times it wouldn't charge at all. I then had a quick battery drain. Engineering believed it to be software issue and exchanged it out for me. I'm wondering if the new backing sensor has anything to do with these issues people are experiencing or if it is purely software.
 

za9ra22

macrumors 6502a
Sep 25, 2003
522
83
Are you using an old charging puck? A stand with the charging puck in it? If so, try the puck that came with the S4, and use it on a flat surface to see if that works.

The reason I suggest this is that my S4 didn't appear to be making consistent contact with my original charging puck on a stand, but charged perfectly on the puck it came with, laying on my bedside table last night.
 

Mikeeee

macrumors 6502
Original poster
Sep 27, 2017
396
245
Are you using an old charging puck? A stand with the charging puck in it? If so, try the puck that came with the S4, and use it on a flat surface to see if that works.

The reason I suggest this is that my S4 didn't appear to be making consistent contact with my original charging puck on a stand, but charged perfectly on the puck it came with, laying on my bedside table last night.
I was using the Series 3 puck with a stand. I tried the new puck and on a flat surface and it did charge. Strange as the Series 3 watch worked fine with the stand. Maybe different dimensions and shape of the Series 4 back makes the previous stand/puck combo non compatible?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.