Azureus and Leopard

Discussion in 'macOS' started by HengenJL, Mar 7, 2008.

  1. HengenJL macrumors 6502a

    HengenJL

    Joined:
    May 27, 2007
    Location:
    Rochester, NY
    #1
    Hello All,

    Hopefully someone here can help me. Ever since upgrading to Leopard I have not been able to get Azureus working properly. I can not get the smilies to go green and I have searched all over the net, including the Azureus/Vuze forums, the forums here, and have not been able to find an answer. I never had an a problem like this in 10.3.9 and this is truly beginning to get on my nerves that I cant get Azureus to go green. With everything being either blue or yellow I know I'm not getting the maximum speed out of Azureus.

    I have 2 routes in my home network: one is a Linksys BEFSR41 V3 and a D-Link DI-624 wireless router. The Linksys has DHCP enabled while the D-Link does not, the D-Link just acts as a wireless access point with WEP enabled.

    I have my PowerBook G4 set with a manual IP address, not using DHCP.
    IPv4: 192.168.1.136
    Subnet Mask: 255.255.255.0
    Router: 192.168.1.1

    The port forwarding on my Linksys is set to 49155, Azureus is pointed to said port. When I do a NAT/Firewall test my results invariably are:
    Testing port 49155 ...
    NAT Error - Connection to xx.xx.xx.xx:49155 (your computer) refused.

    You'll have to forgive me for xx out my non router IP address :p

    In Leopard's firewall I have "Set access for specific services and applications" enabled and under the Advanced tab I also have Stealth mode enabled.

    I am truly at a loss as to how to get Azureus to work properly. Any help is greatly appreciated.

    Sincerely,

    Joe

    P.S. I know some people will recommend that I use Transmission, BitRocket, or another Mac OS X bittorrent client. I have no intention of using any of these programs. I know Azureus and prefer to use something I know, so please dont turn this thread into a flame war over which BT client is better. I asking for serious help here, not a debate over what program is better.
     
  2. heatmiser macrumors 68020

    Joined:
    Dec 6, 2007
    #2
    Under sharing->firewall, select the app name (I'm on azureus too), and hit edit. Enter your port there as well.

    [​IMG]
     
  3. HengenJL thread starter macrumors 6502a

    HengenJL

    Joined:
    May 27, 2007
    Location:
    Rochester, NY
    #3
    I just opened the Sharing preference pane and there is no option for Firewall. at least not in Leopard there doesnt seem to be....
     
  4. heatmiser macrumors 68020

    Joined:
    Dec 6, 2007
    #4
    Yeah, they might have moved it.

    [​IMG]

    What happens when you click on the "+" link? You might be able to add a specific application with the "+" link. From there, perhaps you can reach the edit option to specify the port you want forwarded.
     
  5. HengenJL thread starter macrumors 6502a

    HengenJL

    Joined:
    May 27, 2007
    Location:
    Rochester, NY
    #5
    the "+" under the Set access for specific services and applications only allows other programs to be added. double clicking on a program doesn't do anything either. knowing Apple they probably buried the option that I need in some obscure place within Leopard :rolleyes:
     
  6. richard.mac macrumors 603

    richard.mac

    Joined:
    Feb 2, 2007
    Location:
    51.50024, -0.12662
    #6
    all you need to do is add azureus to the firewall list. you dont need to open a port within Leopard's firewall, only in your router.
     
  7. HengenJL thread starter macrumors 6502a

    HengenJL

    Joined:
    May 27, 2007
    Location:
    Rochester, NY
    #7
    Azureus is already in Leopard's firewall list. That was one of the first things I did when I took a look at Leopard's firewall after I was done updating to Leopard. I activated the "Set access for specific services and applications" option. Then as I use programs that need access to the net I add them to the list. Having the machine constantly open to all incoming connections didnt seem like a wise choice, even with both the Linksys and D-Link having built in firewalls...
     
  8. judzz macrumors newbie

    Joined:
    Jun 7, 2008
    #8
  9. pyr0sphere macrumors regular

    Joined:
    Oct 11, 2007
    Location:
    Toronto, Canada
    #9
    Just turn off Stealth mode. I can almost guarantee that it will work. At least that was the problem for me in Transmission
     
  10. judzz macrumors newbie

    Joined:
    Jun 7, 2008
    #10
    Azureus working with Stealth mode enabled

    Hi pyr0sphere

    I've got Stealth Mode enabled actually. Most important thing is to manually allow incoming connections from Azureus as it normally does not use the regular ports and is by default blocked. All my smilies are green but I sometimes have to reinitiate UPnP advertising on the router to get rid of the yellow ones.

    Hope this helps.
     

    Attached Files:

Share This Page