Azureus behaving funny..

Discussion in 'Mac Apps and Mac App Store' started by Thrash911, Oct 9, 2006.

  1. Thrash911 macrumors 6502


    Sep 14, 2006
    Randers, DK
    I need help. :(

    I installed the BitTorrent client Azureus yesterday, and it has worked fine up until about an hour ago.. When starting the application, there are no graphics and the interface looks garbled, and has funny names in the menu, like.. !! and !! ..

    The console log file reads this:

    ===== Tuesday, October 10, 2006 8:13:26 AM Europe/Copenhagen =====
    java.util.MissingResourceException: Can't find bundle for base name org.gudy.azureus2.internat.MessagesBundle, locale 
    	at java.util.ResourceBundle.throwMissingResourceException(
    	at java.util.ResourceBundle.getBundleImpl(
    	at java.util.ResourceBundle.getBundle(
    	at org.gudy.azureus2.core3.internat.MessageText.getResourceBundle(
    	at org.gudy.azureus2.core3.internat.MessageText.<clinit>(
    	at com.aelitis.azureus.core.impl.AzureusCoreImpl.<init>(
    	at com.aelitis.azureus.core.impl.AzureusCoreImpl.create(
    	at com.aelitis.azureus.core.AzureusCoreFactory.create(
    	at org.gudy.azureus2.ui.swt.Main.<init>(
    	at org.gudy.azureus2.ui.swt.Main.main(
    	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    	at sun.reflect.NativeMethodAccessorImpl.invoke(
    	at sun.reflect.DelegatingMethodAccessorImpl.invoke(
    	at java.lang.reflect.Method.invoke(
    	at apple.launcher.LaunchRunner.callMain(
    	at apple.launcher.JavaApplicationLauncher.launch(
    I tried repairing file permissions (well, you never know as a mac beginner..), but that didn't work.. I have tried to remove Azureus, and all relating files I could possibly find, then reinstalling. No go.

    I know the program is Java based, so it is probably a Java problem. Or am I wrong? I like to solve problems myself, because that's the way to learn best. But this I don't get... :confused:
  2. Thrash911 thread starter macrumors 6502


    Sep 14, 2006
    Randers, DK
    I'm sorry for posting such weird problems.. :rolleyes:

    Finally, I have figured this out. Turned out to be something simple.. In Applications, I had a folder called ! Thrash Apps !, where I put most of my downloaded 3rd party apps, including Azureus. But apparantly Azureus did not like that folder name, it messes things up.. I renamed it to Thrash Apps (removed the !'s), and it worked! :)

    What do you know.. I figured it out by myself anyway.. :eek: This is a possible solution, if others should get the same problem.
  3. xoai macrumors newbie


    Sep 20, 2006
    A Peace Field

Share This Page