B-tree issues with internal hard drive and use of tech tool pro

Discussion in 'Mac Basics and Help' started by fruitey, Feb 13, 2013.

  1. fruitey, Feb 13, 2013
    Last edited: Feb 13, 2013

    fruitey macrumors newbie

    Joined:
    Feb 13, 2013
    #1
    Ive been reading for a long time now and my problem that i've seen a lot of people have still not solved for me. so here I go.

    Attempting to boot up my macbook pro (leopard) - problem b-tree error
    Tried start up disk - no
    Tried holding down different combination of keys on boot up - no
    Taken internal hard drive out placed it in newer macbook pro (lion) (replacing optical drive temporally). Installed tech tool pro 6
    Run surface scan - passed
    Attempted volume repair - failed.
    Either I can't or Tech tool pro wont let me make a disk image (no option for faulty hard drive for the source)

    Additional
    I've a 250 external that i'm wiping as i speak.
    Ive enough room on my macbook pro(lion) to copy all data over
    Im not sure what i can do/ how to get about it.

    please help thank you.
     
  2. AlphaDogg macrumors 68040

    AlphaDogg

    Joined:
    May 20, 2010
    Location:
    Boulder, CO
    #2
    I'm working on the same thing on my friend's drive. My next step is to use diskwarrior to repair the volume. I'll let you know how it goes.
     

Share This Page