Back To My Mac OS X 10.9.x FIX

andijames

macrumors member
Original poster
Sep 2, 2010
59
0
Manchester, UK
Morning all,

Not sure if any of you have been having issues with BTMM not working on Mavericks but i had and i seem to have come across a fix for the issue so thought i would share it as it was driving me crazy and hopefully this can help others out too!

When BTMM stopped working i also noticed that i was having issues connecting with my apple id to machines even if they were on the same local network. I found a way to resolve this and consequently BTMM has started working again for all of my machines.

I think this has something to do with how the apple id is assigned to your user account but let me go through the steps i took for this:

1) Open 'System Preferences'
2) Click on 'Users & Groups'
3) Unlock the padlock in the bottom left corner to make changes
4) Select your user account from the list on the left
5) Right click on account and select 'Advanced Options'
6) In the 'Aliases' box at the bottom you SHOULD have two records (your apple id and another beginning with com.apple.idms.appleid) remove these both and click Ok.
7) In the right hand window on your user account click on 'Change' next to the apple id box.
8) Delete the apple id associated with the account and click 'Done'.
9) Now click 'Set' next to the apple id label (where it just said Change a minute ago)
10) Enter your apple id and password and click ok.
11) After a few minutes the machine should be available again for remote connection and desktop sharing via BTMM. You can always perform a reboot just to be sure.

This should take a few seconds to set and once you have then you can verify this has been set correctly by right-clicking on your user account and selecting 'Advanced Options' to see if it has put the two records in the 'Aliases' box at the bottom.

Needless to say you need an active internet connection for this as it fetches your associated record from your account and aliases it for you.

Perform this task on all the machines that you want to run BTMM on and see if that helps

I hope this helps someone as i was searching for ages for a solution to this and, up to now, this seems the only way to get it working.

Regards

A
 

dangerfish

macrumors 6502a
Aug 28, 2007
551
121
Any thoughts on what to do if the Alias box does NOT populate after following the directions? I still can't get it to work.
 

andijames

macrumors member
Original poster
Sep 2, 2010
59
0
Manchester, UK
It SHOULD populate the alias box if it's not then re-try the process. It did that with me the first time but the second it worked. Maybe worth deleting the settings, unassociating the account and rebooting before re-adding?
 

dangerfish

macrumors 6502a
Aug 28, 2007
551
121
Well, I turned off all the settings in the Sharing pane, turned off BTMM under iCloud and then deleted the Apple id under the Users & Groups settings. Rebooted computer, turned BTMM back on, turned all sharing back on then input the Apple id under Users & Groups and still no joy.
This is so frustrating! It it just the one iMac that is giving me grief. I have no issues with the other 2 Macs (1 older and 1 newer than the iMac in question) and I didn't have any problems with BTMM until I upgraded to Mavericks. Even more frustrating is that when I log into iCloud online, the iMac in questions does show up under Find My iPhone. So it is communicating with iCloud. Just can't connect to it directly from my Air.
 

Mystic Eddy

macrumors regular
Sep 19, 2008
196
16
Staffordshire, UK
Rather than start a new thread, just thought I'd add to this one that BTMM after updating to 10.9.2 has stopped working; it worked flawlessly since getting my MBP Retina 15" and 2TB Time Capsule in November last year and then fell flat since the update to 10.9.2.
Tried the steps listed above but the Alias filed does not populate. My Time Capsule appears in Finder, but the connection attempt always fails. Annoying when I have films and stuff on there that keeps me occupied while out on the road :(.
 

element242

macrumors newbie
Jun 3, 2014
6
1
Found this thread while googling, "Back to My Mac driving me crazy" ha! Great post. I just tried this on my Early 2015 MacBook Pro running 10.13.2 High Sierra and can confirm it worked for me. I can now see my office iMac (only did the alias reset on the MacBook so far).

Thanks for the post andijames!


Morning all,

Not sure if any of you have been having issues with BTMM not working on Mavericks but i had and i seem to have come across a fix for the issue so thought i would share it as it was driving me crazy and hopefully this can help others out too!

When BTMM stopped working i also noticed that i was having issues connecting with my apple id to machines even if they were on the same local network. I found a way to resolve this and consequently BTMM has started working again for all of my machines.

I think this has something to do with how the apple id is assigned to your user account but let me go through the steps i took for this:

1) Open 'System Preferences'
2) Click on 'Users & Groups'
3) Unlock the padlock in the bottom left corner to make changes
4) Select your user account from the list on the left
5) Right click on account and select 'Advanced Options'
6) In the 'Aliases' box at the bottom you SHOULD have two records (your apple id and another beginning with com.apple.idms.appleid) remove these both and click Ok.
7) In the right hand window on your user account click on 'Change' next to the apple id box.
8) Delete the apple id associated with the account and click 'Done'.
9) Now click 'Set' next to the apple id label (where it just said Change a minute ago)
10) Enter your apple id and password and click ok.
11) After a few minutes the machine should be available again for remote connection and desktop sharing via BTMM. You can always perform a reboot just to be sure.

This should take a few seconds to set and once you have then you can verify this has been set correctly by right-clicking on your user account and selecting 'Advanced Options' to see if it has put the two records in the 'Aliases' box at the bottom.

Needless to say you need an active internet connection for this as it fetches your associated record from your account and aliases it for you.

Perform this task on all the machines that you want to run BTMM on and see if that helps

I hope this helps someone as i was searching for ages for a solution to this and, up to now, this seems the only way to get it working.

Regards

A
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.