Back to my Mac says Disable a NAT device?

Discussion in 'macOS' started by RoboCop001, Oct 22, 2009.

  1. RoboCop001 macrumors 65816

    Joined:
    Oct 4, 2005
    Location:
    Toronto, Canada
    #1
    Hi there.

    I'm trying to get Back to my Mac working, but it's saying that I have more than one device that's using NAT, and to disable NAT on one of those devices.

    I've attached a screen shot....

    Here's my setup...
    DSL Modem + DIR-655 (DLink wireless router).

    Could both of those have NAT enabled? I obviously wouldn't be able to disable NAT on the modem if it does, but how do I do this on my router?

    I've googled like crazy and I can't find the solution.

    I've disabled both the DNS Relay and the DHCP server on my router.

    The firmware of this router is 1.11. Should I update it?

    Any ideas?

    I'm running Snow Leopard.

    PS.
    Why can't I get 802.11n speeds? I've attached a related screenshot. It says PHY Mode is wireless n, but the speed is only 54? Happens with every N router I try to connect to.

    I have a Late 2006 MBP that I installed the Wireless-N Enabler on.
     

    Attached Files:

  2. RoboCop001 thread starter macrumors 65816

    Joined:
    Oct 4, 2005
    Location:
    Toronto, Canada
    #2
    I solved my NAT problem and Back to my Mac now works.

    I had to have DNS Relay on, and DHCP server off, with the modem plugged into one of the LAN ports instead of the WAN port.


    But does anyone have an idea of why I can't get N speeds? I installed the N enabled on my MBP.
     

Share This Page