Back to My Mac- Yosemite (NAT-PMP & UPnP)

Discussion in 'Mac Basics and Help' started by Ben1l, Nov 6, 2014.

  1. Ben1l macrumors regular

    Joined:
    Nov 30, 2006
    #1
    I'd like to use Back to My Mac, between two of my Macs, a Mac Pro (trash can) and a Macbook Pro 2011.

    When I go a finder of my Macbook Pro and look in the shared section, I can't see my Mac Pro.

    When I click on details of Back to My Mac in iCloud settings I get this error...

    "Back to My Mac may be slow because NAT Port Mapping (NAT-PMP) or Universal Plug and Play (UPnP) is turned off on your router.
    Turn on NAT-PMP or UPnP."

    I have a Timecapsule that I use my router. I've gone into the settings and and added my apple ID in the Back to My Mac section. It has a green light in the status".

    I've also gone into my Sky (UK) modem/router settings and made sure UPnP is turned on. For some reason that I don't understand, when Sky installed my Fibre they also put in a BT Openreach box.

    I don't know how to access this box's setting.

    Is there anything I need to do on the Macbook Pro to get the Mac Pro to show up??

    Any other advice on how to get this working would be appreciated!
     
  2. 98EXL, Nov 18, 2014
    Last edited: Nov 18, 2014

    98EXL macrumors regular

    Joined:
    Jun 16, 2012
    Location:
    not on the moon
    #2
    I'm in Starbucks right now trying to troubleshoot the same damn thing. I've been trying for about a week trying to get this pig to work...it works great when I'm home on the local network. Here's what I've done so far:

    Abridged setup: late 2012 mac mini at home with a 6th gen AEBS, and a late 2013 rMBP

    1. Read the directions, yay! It works at home.
    2. Also enabled the BTMM on the AEBS, I can see that perfectly fine from currently a Goolge Fiber connection. (doing some troubleshooting earlier on my visit shows it's probably a Fios connection). I have also been able to see my AEBS in the Airport Utility from 3 different ISP's, with zero issues whatsoever.
    3. Still nowhere, I read an Apple KB Article discussing enabling NAT Port Mapping and setting the default host to the 'MacMini' Did that, and setup a DHCP reservation for eth0....it pisses me off wifi needs to be on for AirDrop....I get it, but really, there is GigE everywhere!!!???!?!?!?!
    4. Still no dice, the AEBS is supposed to be fine out of the box, but at this point I don't know if my list of ports that need to be open is right, I assume it is.
    5. Double checked the security settings in the toubleshooting KB article on the mini, still nothing.
    6. No errors in the iCloud console pertaining to BTMM....
    7. Wish expresso had whiskey in it....


    edit:
    went to double check the ports on my router:
    Back to my Mac Ports

    Port TCP/UDP name RFC name
    443 TCP SSL 2818 https
    500 UDP ISAKMP/IKE 2408 isakmp
    1900 UDP SSDP - ssdp
    4488 TCP Apple Wide Area Connectivity Service - awacs-ice
    4500 UDP IPsec NAT Traversal 4306 ipsec-msft
    5223 TCP Apple Push Notification Service - -
    5350 UDP NAT Port Mapping Protocol Announcements - -
    5351 UDP NAT Port Mapping Protocol
    5353 UDP Multicast DNS (MDNS) 3927 mdns
    49152-65535 UDP - - -

    When I tried to add UDP 500, I got an error from the AEBS stating that port was already in use. That makes me believe that the required ports are setup correctly
     

Share This Page