Back to my Mac

Discussion in 'OS X Yosemite (10.10)' started by Mufasa804, Oct 21, 2014.

  1. Mufasa804 macrumors regular

    Joined:
    Mar 6, 2009
    #1
    Hello,

    Whenever I try to Share Screen (MacBook Pro 10.10) from my iMac (10.10) I get the following error:

    "Connection failed to 'MacBook Pro'.
    Please make sure that Screen Sharing (in the Sharing section of System Preferences) is enabled on the computer to which you are attempting to connect. Also make sure your network connection is working properly."

    All my settings and set to go and I'm logged into my iCloud account on the laptop. What's weird is that this doesn't seem to happen when I try to to access another MacBook Pro (10.9.5) from the same iMac (10.10).

    Anyone else having this issue? Any fixes yet?
     
  2. podlasek macrumors newbie

    podlasek

    Joined:
    Feb 28, 2008
    Location:
    USA
    #2
    I have this same issue, it appears that Back to my mac is broken under yosemite:mad:, that is unless someone has come up with a fix/workaround?

    What's wierd is it worked until I upgraded both machines?

    I also have verified all the settings.

    as a note, it seems to work if both machines are on the same network, only when accessing from external does the issue arise.
     
  3. kissmo macrumors 6502a

    Joined:
    Jun 29, 2011
    Location:
    Budapest, Hungary
    #3
    I have the same issue since Yosemite RC 1
     
  4. Mufasa804 thread starter macrumors regular

    Joined:
    Mar 6, 2009
    #4
    It's definitely a Yosemite issue. After doing some playing around I have gotten the following settings to work (with some issues):

    iMac - OS X 10.10

    Screen Sharing [ON]- "Allow Access for (x) Only these users:"
    In the white box I don't have any users added.

    File Sharing [ON] - Under options I only have AFP checked.
    Under Shared folders I have my Macintosh HD, with my user as Read and Write access.

    Remote Login [ON] - "Allow Access for (x) Only these users:"
    In the white box I have myself added..

    ------

    Now when I open Finder I am able to see my Time Capsule and my 10.9.5 machine right away. I'm able to sign in and access my files/screen share no problem.

    My MacBook Pro (10.10) however, takes anywhere from 2-4 minutes to appear as an accessible computer. Super annoying but it works. Let me know if you have any success with this.
     

Share This Page