Background pic disappears when I boot my mbp

Discussion in 'macOS' started by nissin, Jun 18, 2009.

  1. nissin macrumors newbie

    Joined:
    Mar 19, 2008
    #1
    after restarting my mbp one day (1.5 years old, 2.6 ghz intel, 4 gb ram), my dock loaded, icons appeared, my background pic appeared and everything seemed to load like normal. then after about 5 seconds, itunes opened by itself and at that instant my background turned from my pic to just a white screen. itunes then launched normally, and everything worked fine. i tried to close itunes, which i did successfully, and the screen was still white. i then tried to reset my background to my previous pic. the settings box shows that the pic should be set, but it won't show up on my desktop.
    the weird thing is, when i swipe to a corner to show all windows or to show my desktop the pic reappears.
    it has been happening for about a month or so, and i'm finally fed up with it. i installed the firmware update that was released a few days ago and thought that might do something, but it didn't.

    too lazy to read...
    after rebooting/starting, itunes opens automatically, and simultaneously my background pic disappears on my desktop and only shows a white screen and will not come back, even after resetting the background in settings. other than that, my laptop works fine.

    has anyone else had this happen? could this be an easy fix, or could i have to reinstall osx? thanks for the help, i've searched a couple different sites and apple help with no solutions.
     
  2. MWPULSE macrumors 6502a

    MWPULSE

    Joined:
    Dec 27, 2008
    Location:
    London
    #2
    As opposed to having to reinstall the whole OS.. Try making a new account in preferences-accounts and see if you still have the problems.

    There is also a preferences file (.plist) somewhere as well which deleting might well help.. but i cant remember where it is!

    Sorry i cant be of more help!!

    PTP
     
  3. nissin thread starter macrumors newbie

    Joined:
    Mar 19, 2008
    #3
    my guest account works fine, itunes doesn't start automatically and the background pic stays up.

    also, on my account, i have not selected "open at login" for itunes.
     

Share This Page