iPhone Backgrounded apps killed automatically?

Discussion in 'Jailbreaks and iOS Hacks' started by spotsphill, Feb 23, 2013.

  1. spotsphill macrumors regular

    Joined:
    Sep 26, 2009
    #1
    Has anyone experienced certain apps being closed automatically when sitting in the background? I've particularly noticed this with a few of my podcasting apps (Downcast & Instacast to be exact -- Downcast is considered to be one of the best podcasting apps out there so I don't think it's the app). I'll pause the audio to do something else for a little bit and then I'll go back to play the audio and it'll resort back to playing the most recent song from my stock Apple Music app. When I check the running processes with SBSettings, it doesn't show that Downcast is running.

    Is this a glitch in 6.1? Could it be a problem with one of the jailbreak apps/tweaks? I hadn't experienced this on my iPhone 5 prior to jumping to 6.1/jailbreaking. Anyone else having this problem?
     
  2. Redjericho macrumors 6502a

    Joined:
    Sep 16, 2011
    #2
    The OS automatically kills backgrounding apps that aren't running whenever RAM gets tight. If you pause the podcast and start opening new apps/tabs in safari, RAM will get used and backgrounded apps will close.

    If you're saying that the podcast will just stop playing in the middle of you listening to it and the app will close, then that is a bit more weird.
     
  3. spotsphill thread starter macrumors regular

    Joined:
    Sep 26, 2009
    #3
    While this makes complete sense to me, what doesn't make sense is why this just started happening. I haven't changed the way I use my phone in the slightest. I have the SBSettings' free memory indicator in my status bar so I'll restart my phone and kill all but Downcast to see if this happens with max available RAM.

    No, it never crashes the app when I'm in it...only when in the background. Thanks for the help; this is really puzzling to me.
     
  4. Redjericho macrumors 6502a

    Joined:
    Sep 16, 2011
    #4
    One possible work around, get the "Auto App Killer" tweak from cydia, and set Downcast as an app to never be killed in the background. This isn't the tweaks intended purpose, but it does have this functionality.
     
  5. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #5
    Very strange. I use tunein radio all the time and I never have any problems like this. If you figure out what's causing this please post here.
     
  6. doasis23 macrumors regular

    doasis23

    Joined:
    Aug 23, 2012
    #6
    I'm having the same issue too with podcasts and maps. Trying to figure out whats causing it. Thought it was one of my emulators or clock builder but cant narrow it down.
     
  7. robotphood macrumors 6502a

    Joined:
    Jun 25, 2010
    #7
    This is odd. I've been noticing this the past week. It's not just limited to maps or audio apps for me. I'm also trying to narrow it down. I recently was force to restore my phone and dumped a few tweaks along the way. I'm keeping an eye out for this to reoccur.
     
  8. spotsphill thread starter macrumors regular

    Joined:
    Sep 26, 2009
    #8
    Well at least I feel a little better about my situation knowing that others are having this problem. I'm still on 6.1; is anyone having this problem on 6.1.1 or 6.1.2?
     
  9. robotphood macrumors 6502a

    Joined:
    Jun 25, 2010
    #9
    I know for sure I didn't experience it in 6.1 before the jailbreak and about a week or so after jailbreak. I'm currently on 6.1.2. Haven't noticed it happening (seemed a bit random before) but I haven't been on it long. I will try to reproduce it. BTW, do you have switchy installed? That's when I first noticed it (but it may have occurred before that).
     
  10. iALLOUT4eva macrumors regular

    iALLOUT4eva

    Joined:
    Oct 3, 2012
    Location:
    PlayDay Land
    #10
    Im having a b very similar problem. My phone will start ending backgrounded apps when ram is below 200!!! Its limiting me to having only a couple apps open when I can have many more but as soon as its drops below 200 it deletes apps why?! Never had this prob before jailbreak.
     
  11. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #11
    Now that I think about it, I remember reading a week or so ago that some people said winterboard was causing backgrounded apps to force close. I'll do some searches and see if I can find it. I'm pretty sure that's what they were saying. Who is experiencing this problem and has winterboard installed? I'm not sure how or why winterboard would cause it though.
     
  12. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #12
    I use winterboard and haven't run into that problem.
     
  13. iALLOUT4eva macrumors regular

    iALLOUT4eva

    Joined:
    Oct 3, 2012
    Location:
    PlayDay Land
    #13
    Yes I haves winterboard installed along with the ayecon theme. Plz let me know something
     
  14. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #14
    I just did a quick search. This is the thread where I read winterboard was causing backgrounded apps to close.

    http://forums.macrumors.com/showthread.php?t=1545558&highlight=winterboard+background

    I can't confirm or deny this though. I don't use winterboard. You can try what these posters said worked and temporarily disable or remove winterboard and REBOOT the phone and see if background apps are still closing. If they behave normally then you know winterboard is giving you this problem. If they're still not behaving correctly then you know winterboard is not the cause. If its the latter, at least you'll be 1 step closer to solving the problem! But I suspect it's winterboard since these people were also having this same problem. But like I said, I don't use winterboard so my information is soley based on what is discussed in that thread. Good luck and let us know what you find out!
     
  15. iALLOUT4eva macrumors regular

    iALLOUT4eva

    Joined:
    Oct 3, 2012
    Location:
    PlayDay Land
    #15
    Thanks a ton! You really help ppl on these forums out a lot. Plz continue to be the macrumors Guru that you are #

    ----------

    Guys! For me it was a conflict with the ayecon 2x2 folder layout settings. I turned it off and all is well. Back to having 15+ apps backgrounded!!
     
  16. BumpyFlatline, Feb 23, 2013
    Last edited: Feb 25, 2013

    BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #16
    Sweet! I'm glad that was the problem. Nothing worse than disabling a ton of tweaks and still not finding the culprit. I'm glad I could help you. This is why I signed up. And thank you for the kind words. :) Although I'm nowhere near the gurus that are dhlizard, applejuiced, labman, TriJet, Intell...
     
  17. robotphood macrumors 6502a

    Joined:
    Jun 25, 2010
    #17
    Thanks for the link Bumpy. I posted a reply in it. I have had ayecon 2x2 as well from the first day (and still do now) and didn't notice anything. I'm wondering what it really is.
     
  18. spotsphill thread starter macrumors regular

    Joined:
    Sep 26, 2009
    #18
    I uninstalled Winterboard and it's working properly! Thanks Bumpy..
     
  19. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #19
    No problem! Glad I could help!
     
  20. Bitgod macrumors regular

    Bitgod

    Joined:
    Oct 25, 2003
    #20
    Hmm, its something I've noticed happening on my 6.1 ipad the past few days, I figured it was either something I hadn't noticed before, or a product of installing BatteryDoctorPro.
     
  21. wknapp0924 macrumors 6502

    Joined:
    Sep 14, 2012
    Location:
    Honolulu, HI
    #21
    I thought it was Auxo, then uninstalled winter board and nothing has closed on its own since then. I miss my custom theme, but winter board sucks the memory I guess.
     

Share This Page