Backgrounder.app causing Email.app to NOT receive mail via Push (Please HELP)

Discussion in 'Jailbreaks and iOS Hacks' started by Katin, Sep 28, 2009.

  1. Katin macrumors regular

    Joined:
    Jun 18, 2008
    #1
    Well, just to give everyone a heads-up... I installed Backgrounder and I had to ALWAYS open Mail.app first thing in the morning to have it run in the Background which was really annoying. So, what I did was Uninstalled Backgrounder and rebooted my iPhone several times, turned Mail Push On and Off, Rebooted again and still nothing. Any suggestions on how to make the Mail.app work properly again?

    WORSE case scenario would be either install Backgrounder again and do the same thing every morning... or UnJailbreak my iPhone.... Any ideas???

    (It is possible I'm missing a setting in Backgrounder where it allows you to select which Apps you'd like to Run in the background automatically.... Is there?)

    Thanking you all in advance
     
  2. Mess macrumors 6502

    Mess

    Joined:
    Nov 27, 2008
    Location:
    Newcastle Upon Tyne, UK
    #2
    i have backgrounder installed and push enabled on my gmail account. Everything works fine.

    Have you altered any settings in backgrounder to forbid mail.app from running or anything like that?

    If not, restore is the route. :rolleyes:
     
  3. pauliphone macrumors regular

    Joined:
    Nov 27, 2008
    Location:
    London, UK
    #3
    as above, i have backgrounder and no problems with push email, sounds like it is a conflict or something to do with the settings on your phone.
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    The mobileMail.app and phone.app always run in the background on the iPhone, with or without Backgrounder.

    Not sure what you might have done, but I have Backgrounder and have no interference with MobileMail.app. I have always just let it do it's thing and never tied it to backgrounder.

    Did you mess with something trying to get rid of the backgrounder badges that show up on mobilemail.app and phone.app when backgrounder is enabled ?
     
  5. polobreaka macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #5
    my mail and backgrounder works as well.

    try to reinstall and see what happens?
     
  6. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #6
    I don't think the problem is Backgrounder. Something else must be causing your issue.
     
  7. Katin thread starter macrumors regular

    Joined:
    Jun 18, 2008
    #7
    Thanks everyone, I will def research this tomorrow and try to restore all the settings I had one Backgrounder and this other app called Kirake. If this doesn't work I'll just restore. Thanks again
     
  8. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #8
    MobileMail works fine with Backgrounder and Kirikae on my phone.
     
  9. Katin thread starter macrumors regular

    Joined:
    Jun 18, 2008
    #9
    Ok, I found the problem... It appears that when you install Supreme Preferences 3.0, it turns OFF Backgrounding for Mail.app. I turned it back on and it works great!

    Thanks to all that was trying to help me.
     

Share This Page