Backlight on main iPhone screen won't close

Discussion in 'Jailbreaks and iOS Hacks' started by sallymomo, Jan 6, 2011.

  1. sallymomo macrumors newbie

    Joined:
    Jun 9, 2009
    #1
    So a friend of mine re-jailbroke/unlocked my Iphone with the 3.1.2 version and now i am seeing that the light on the main screen (where it has the clock and says slide to unlock) never turns off unless I close it from the top. And so...when ever I get a text message and if the phone is in my purse, the light just stays on and I drain alot of battery.
    I have checked the settings for auto-lock and its set to 1 minute. And the 1 minute works fine if I am on any other screen (like mail, game etc) but the light just never goes off on the main screen.
    Can someone help??
    Thanks
     
  2. hoogen macrumors regular

    hoogen

    Joined:
    Jun 22, 2010
    #2
    hmm, have you tried doing a hard reset? (holding the power and home button at the same time untill the phone turns off). whenever i have a small problem that always seems to fix it.
     
  3. sallymomo thread starter macrumors newbie

    Joined:
    Jun 9, 2009
    #3
    Just tried the hard reset...and it didn't work...The main screen still stays on...So frustrating :mad:
     
  4. KentuckyHouse macrumors 68020

    KentuckyHouse

    Joined:
    Jan 29, 2010
    Location:
    Lexington, KY.
    #4
    Do you have SBSettings installed? I know you said you checked the Backlight settings in General Settings, but there's also a toggle in SBSettings that can turn the Autolock off and on. It's possible this has gotten set to "off" so the Autolock doesn't engage. Just another option. :D
     
  5. sallymomo thread starter macrumors newbie

    Joined:
    Jun 9, 2009
    #5
    How would I check for SBSettings...is it something that you install with Winterboard? I don't think I have SBSettings but I wouldn't know where to look...I don't see it in setup so I am thinking I don't have it.

    Edited: Ok I don't have SBSettings..I googled it and definitely don't have it installed.
     
  6. sallymomo thread starter macrumors newbie

    Joined:
    Jun 9, 2009
    #6
    After 3 months, I am still seeing this issue and its sooo frustrating. I think I tried the SBSettings and it didnt' work either. My battery totally drains when I loose network, get a text etc.

    Thank god my pings don't work with this version on my phone (yet another issue) ... else my fb pings would totally kill my battery.

    Does anyone else know a simple solution to fix this problem?
     
  7. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #7
    Simple solution would be change it to another phone. Preferably any dumb phone so you don't have to worry about all these tech stuff.

    Or you can try to restore and see if the problem disappear. If it does then it's JB problem. If not then it's your phone's problem.
     
  8. sallymomo thread starter macrumors newbie

    Joined:
    Jun 9, 2009
    #8
    I don't think its a phone problem because this started happening only after the phone was jailbroken.
     

Share This Page