Backlit keyboard problems

Discussion in 'MacBook Air' started by stevenpa, Jul 28, 2011.

  1. stevenpa macrumors 6502

    Joined:
    Jun 28, 2011
    #1
    Is it a Lion bug or software related when the backlit keyboard is locked? When I try to change the intensity and turn it on/off I'm getting this symbol below the bars [​IMG]

    It's letting me change every once in a while but most of the time it's not locked.

    Any ideas? Running Office, Chrome, Meeting software and Skype.
     
  2. HellDiverUK macrumors 6502

    Joined:
    Oct 24, 2009
    Location:
    Belfast, UK
    #2
    It'll be LION. It won't let me change my volume either, it's stuck at full volume. Lion is the worst OS from Apple yet. The fail is very strong with this version.
     
  3. stevenpa thread starter macrumors 6502

    Joined:
    Jun 28, 2011
    #3
    Ok. I don't really use the backlit keyboard but for those who do this will be a stickler.
     
  4. skeevewiz macrumors newbie

    Joined:
    Jul 26, 2011
    #4
    Hey there, found this exact same thing...would literally work, then not work, then work in a matter of 1 minute. Found a fix I think.

    In System Preferences, goto Keyboard and there is a setting "Automatically illuminate in low light". If you uncheck that it should ALWAYS work. Just drain more battery.

    Hope that makes sense - give it a try and it should work right away.
     
  5. Patriot24 macrumors 68030

    Patriot24

    Joined:
    Dec 29, 2010
    Location:
    California
    #5
    Yes, when the option is checked the backlight only comes on and is adjustable when low light is detected by the ambient light sensor. If you disable the option, then you are able to control the brightness and drain your battery as you see fit.
     
  6. NutsNGum macrumors 68030

    NutsNGum

    Joined:
    Jul 30, 2010
    Location:
    Glasgow, Scotland
    #6
    Yappity, yappity, yappity.

    Clearly you didn't try OS9.
     
  7. stevenpa thread starter macrumors 6502

    Joined:
    Jun 28, 2011
    #7
    I've had the option checked since I got my MBA monday and I could always control the intensity and turning it on/off until today. When I had it checked, I could turn off the backlight when I wanted to, but it also turned on automatically when it was darker. Now I lost the option to do that?
     
  8. Beanoir macrumors 6502a

    Beanoir

    Joined:
    Dec 9, 2010
    Location:
    51 degrees North
    #8
    I was hoping for a BLK free forum following the new release..
     
  9. marzxbarz macrumors member

    Joined:
    Apr 23, 2009
    #9
    Try covering the ambient sensor (around the camera) with your hand, and then changing the backlight intensity level. The restriction you are seeing only occurs when the MBA detects that the illumination is not necessary since it is already bright enough.

    As for sound, however.. That has only occured to me when I had an optical cable in the headphone out port.. but seeing as the Airs don't have an optical out, that is strange..
     
  10. stevenpa thread starter macrumors 6502

    Joined:
    Jun 28, 2011
    #10
    Thanks for the info, it worked!
     
  11. eckthroi macrumors regular

    Joined:
    Mar 10, 2011

Share This Page