Backspace and Delete key not working

Discussion in 'iMac' started by Matteh, May 31, 2013.

  1. Matteh macrumors newbie

    Joined:
    May 31, 2013
    #1
    Hello, my backspace and keyboard button arn't working! I am currently on a Mac OS X 10.7. I am typing this from an old keyboard that I had that had a USB plugged into the mac. Not even when I press shift or fn and backspace/space does it work. Just when I push the button, it doesn't work/register. It worked fine yesterday and was just working 1-2 hours ago, then it derped up. I restarted my computer, it worked fine then when I left for a minute and came back it wasn't working with backspace and space. the keyboard and mouse are wireless. Thanks! Please Please help!
     
  2. seveej macrumors 6502a

    seveej

    Joined:
    Dec 14, 2009
    Location:
    Helsinki, Finland
    #2
    If you've tried restarting moth the machine and the keyboard, and one key/button does not function, then most probably, that key is broken, especially, if the function (backspace/delete) works on other connected keyboards...

    RGDS,
     

Share This Page