Backup disk failing?

Discussion in 'MacBook' started by Xenophon, Aug 3, 2010.

  1. Xenophon macrumors regular

    Joined:
    Apr 8, 2010
    Location:
    New Delhi, India
    #1
    I use time machine to back up my data to a 300 Gb external iomega disk that I purchased back in 2006. Yesterday, Time Machine could not complete a backup and returned a 'Could not create the backup folder' error. I ran disk utilities and it returned a host of errors, ending with the message that the disk is corrupt, could not be repaired and I had to back up my data immediately. The data on the disk was however, still accessible.

    While I was already looking at ordering another disk, Time Machine successfully completed a new backup on the iomega (I didn't do anything). Ran disk utilities again--> same message about a corrupt disk that was unrepairable. Anyway, this morning I run disk utilities again, this time it repaired everything (matching table counts etc).

    So, is everything peachy again or should I replace it anyway? All my really critical files are backed up automatically over the net to an off-site secure location, in addition to the regular backup on time machine. I just want to avoid the scenario of losing access to all my historical backups but at the same time, creating backups of backups begins to look foolish.
     
  2. tersono macrumors 68000

    tersono

    Joined:
    Jan 18, 2005
    Location:
    UK
    #2
    Could well just be disk corruption rather than a hardware issue. Sometimes fsck takes several passes to fix major issues.
     

Share This Page