Backup to network drive

Discussion in 'OS X Yosemite (10.10)' started by Ernie11, Mar 18, 2015.

  1. Ernie11 macrumors member

    Joined:
    Apr 4, 2014
    #1
    Hello everyone. I have been trying to get this to work for a while now and im getting no where. When I had Mavericks I would have it backup to a .sparsebundle on my home server running windows xp. Now with yosemite no matter what I do I cant get it to work. I have made the sparsebundle with my local name and MAC address, then moved it to the backup folder on my windows xp server, I have tried mounting it, not mounting it, with SMB on and AFP on, with both off, with one on one off, I have tried to mount it straight into TM by doing "sudo tmutil setdestination /Volumes/Backups/"the name I gave it".sparsebundle and I get this error "Incompatible file system type: smbfs (error 45)", I tried without the .sparsebundle, nothing seems to work. Any ideas? Its a bit frustrating considering that I got it working on Mavericks on my first try with no problems at all. Thank you.

    Ernie.
     
  2. steveyo macrumors regular

    Joined:
    Feb 2, 2015
    #2
  3. Taz Mangus, Mar 18, 2015
    Last edited: Mar 18, 2015

    Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #3
    I believe Apple removed backup over SMB in Yosemite. Backup over AFP still works though in Yosemite.

    EDIT: Try this format for tumuli:

    sudo tmutil setdestination "smb://<user>:<passoword>@<ip address>:/<backup hard drive name>"​

    The above command requires that you have assigned a fixed IP address to the computer where the backup hard drive resides. You also need to have file sharing turned on on the other computer for the hard drive.
     
  4. steveyo macrumors regular

    Joined:
    Feb 2, 2015
    #4
    Not true
     
  5. Taz Mangus, Mar 18, 2015
    Last edited: Mar 18, 2015
  6. Ernie11 thread starter macrumors member

    Joined:
    Apr 4, 2014
    #6
    I tried one more way. When I made the sparsebundle I made it with my local name and MAC address but also gave it a name. I tried to use the name this time and got this. Am I missing something? Seems closer than before.
    (computer anme):~ Ernie$ sudo tmutil setdestination /Volumes/Black Diamond
    Usage: tmutil setdestination [-a] mount_point
    tmutil setdestination [-ap] afp://user[:pass]@host/share
     
  7. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #7
    See my suggestion in post #3 above.
     
  8. Ernie11 thread starter macrumors member

    Joined:
    Apr 4, 2014
    #8
    Hi Taz, I tried doing it that way too and all I got was ">" on my terminal.

    I have Tuxera installed on my mac, could this be doing it?
     
  9. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #9
    My mistake. I left off a closing quote. I fixed it, look at post #3 again.
     
  10. Ernie11 thread starter macrumors member

    Joined:
    Apr 4, 2014
    #10
    I get this again:
    Usage: tmutil setdestination [-a] mount_point
    tmutil setdestination [-ap] afp://user[:pass]@host/share
    I dont have a password so i leave it blank without the brackets. is that ok?
     
  11. Taz Mangus, Mar 18, 2015
    Last edited: Mar 18, 2015

    Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #11
    Do you have sharing setup on the windows machine?

    According to the man page for tmutil:
    This gives me the impression that you can't use SMB for this purpose.
     
  12. Ernie11 thread starter macrumors member

    Joined:
    Apr 4, 2014
    #12
    I can see the folder and file on my mac computer, I put the sparsebundle in the folder from my mac to the windows computer through the shared folder.

    Edit: I see lots of articles on how to do this with Mavericks and under but non with Yosemite.
     
  13. Taz Mangus, Mar 18, 2015
    Last edited: Mar 18, 2015

    Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #13
    I am curious as to how you use SMB to network backup using Time Machine.
     
  14. Ernie11 thread starter macrumors member

    Joined:
    Apr 4, 2014
    #14
  15. Ernie11 thread starter macrumors member

    Joined:
    Apr 4, 2014
    #15
    Well if anyone knows a work around, it would be really appreciated if you shared it.

    Ernie.
     
  16. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #16
    When I was running Mavericks I was doing a network backup from my MacBook Pro to my iMac, which has a Time Machine hard drive on it. The article you posted is how it worked. I simply mounted the network hard drive on the MacBook Pro and selected it in Time Machine preferences.

    When I switched to Yosemite I was not able to do that any longer. I had to use the command: tumutil setdestination -ap "afp://...". Point being, it appears that the document is not correct for Yosemite. This is the part I am referring to:
     
  17. Ernie11 thread starter macrumors member

    Joined:
    Apr 4, 2014
    #17
    Im not sure. When yosemite came out to the public I updated and ever since I havent been able to do a backup this way. Im trying with Tuxera on and off and all the possible combinations with the SMB and AFP on and off. Nothing seems to work. I keep getting the same error.
     
  18. Ernie11 thread starter macrumors member

    Joined:
    Apr 4, 2014
    #18
    I got it working! I dont know how but I did. I kept making more sparsebundles and repeating and repeating and using tmutil over and over again and it appeared. Its backing up now. My settings ended up being: tuxera on(if this made any difference at all), AFP on and SMB on. Now I have to get ride of all those sparsebundles in my trash. Thanks for all help taz.
     
  19. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #19
    Not that I did much to help, glad it turned out working for you.
     

Share This Page