"backup to this computer" not working

Discussion in 'iPod touch' started by avillabon, Jun 27, 2012.

  1. avillabon macrumors newbie

    Sep 4, 2011
    I have an ipod touch 4g and today I wanted to backup to my computer instead of icloud. I went on to itunes and switched from "backup to icloud" to "backup to this computer" then when I hit "apply" it just switches the selection to the icloud option. How can I fix this? I want it to backup to the computer but it keeps switching. I tried rebooting, closing and opening itunes etc... nothing works. I also checked the directory where the backup files should be and it is empty.

    Any ideas?


  2. JediMeister macrumors 68040

    Oct 9, 2008
    It's possible you have to disable the backing up to iCloud from the device itself first before disabling it from within iTunes. Also, if you just want to backup the device once to the computer, you don't have to disable the backing up to iCloud to do so. Just right-click the device name in the iTunes source list and choose the option to back up. You will have to do this manually until you turn off iCloud backups completely.
  3. class77 macrumors 6502a


    Nov 16, 2010
    What an awesome tip, Jedi Master!! I haven't heard anybody giving that shortcut before and it's a really useful one. Thanks again
  4. classics95, Jul 14, 2012
    Last edited: Jul 14, 2012

    classics95 macrumors newbie

    Jul 14, 2012
    RE:"backup to this computer"

    Try this website, my pc back up
    it backs ups everything from music, videos, photos, files for FREE!!! My Pc Back Up
    Heres the link, and its a pretty legit website.

Share This Page