iPhone Bad experience with jailbreak

Discussion in 'Jailbreaks and iOS Hacks' started by megadon, Nov 25, 2014.

  1. megadon macrumors 6502

    Joined:
    Dec 5, 2008
    #1
    Background info: I've jailbroken my iPhones before, but stopped after things like FaceTime over 3g and stuff like that actually got released. Anyways, I had an iPhone 5 that was one of the ones eligible for battery replacement due to horrible battery life. I decided to jailbreak it anyway, which could have been my first mistake.
    Long story short, I started having issues with the phone not recognizing any chargers, then to the point where it would only charge when the phone was off.

    I decided to erase data and content before taking it to the apple store for a battery swap. So here is where it gets annoying.

    On the apple website it states to "Erase data and settings in Settings > General > Reset > Erase all Content and Settings"

    But on the same page of the website it also states that "If your iPhone is in working order and exhibits the symptoms noted above, use the serial number checker below to see if it is eligible for this program"

    So after I clicked "erase all content and settings" my phone went into a permanent loop of rebooting with no progress. iTunes would not recognize it tried DFU, different cord, different computer, even a windows computer, no luck.

    So i take it to genius bar today, and long story short, the guy tells me just because my serial number was eligible for battery replacement didn't mean I have a battery issue, and because my phone is not in "working order" my only choice was to buy another iPhone 5 for 300. Pretty much my phone became a paper weight. Turns out the mother board was done..

    He wouldn't agree that it was a catch 22 that I was following instructions on the battery replacement page and reset the phone, which caused the reboot problem. Before that it was working, but only would charge when power was off.

    I know I said long story short, but anways, called apples 1800 number, and the guy talked to a senior specialist or something, and he was so helpful. He said it seemed like "i had some bad luck today" and wrote a memo for the apple store to replace the iPhone 5 for me. He even made my apple genius appointment for me.

    So I went back made sure it was the same "genius" and just said "I'm here to pick up my new phone" he looked confused, but eventually some other girl came and gave me a new (refurbished iPhone 5)

    all in all, I was getting really annoyed during the first appointment and I lost a little faith in apple, then a real apple employee really helped me out and restored my faith. As long as I get a defective phone replaced by the company that sold it to me I'm happy.

    But this kinda makes me think its possible to mess your phone up with jailbreaks, could it be possible the jailbreak caused the issue?

    Now i'm thinking I'm probably not gonna jailbreak it.. I was on iOS 8.1 and using the Yosemite with newest iTunes..

    Did I brick my phone? or did apples defective battery somehow cause it?
    Did my phone get stuck int he infinite restore window because it was jailbroken? Is it possible for a bad battery to kill the mother board?
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    No, the jb does not cause any permanent hardware issues. It's only software and a restore will fix any software bugs.
    But going by what you say and did above you should stay away from ever jb again.
    It's not for you.
     
  3. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #3
    You didn't brick your device. Since iOS 5, when jailbroken performing a reset of iOS in the fashion you did causes it to do that. When pressing both buttons to hard reset it, causes the device to restart as if nothing had happened. You were able to restore via DFU mode, but due to a hardware problem or user error, were unable to.
     
  4. aPple nErd macrumors 68030

    aPple nErd

    Joined:
    Feb 12, 2012
    Location:
    Jailbreaks/IOS Hacks
    #4
    lol. what a fail on the OP's part. maybe you should have made sure erase all content and settings wasn't going to mess up the SOFTWARE when you are jailbroken. its pretty much common knowledge now...
     
  5. megadon thread starter macrumors 6502

    Joined:
    Dec 5, 2008
    #5
    wow, I guess that just shows how stupid I was. I can't disagree and say I wasn't the cause of this. However, I only did the "reset" on iOS due to the fact that I felt like it was my last resort, by that point I could never connect the iPhone to iTunes for a proper restore, as iTunes would not recognize it at all.

    I always found Jailbreaking really simple if you do your reading, so I guess I'm gonna read on it for a while before Jailbreaking this new phone.

    But just to confirm, the fact that I reset all settings in iOS while it was jailbreaking will cause it to go into an infinite reboot cycle, which is fixable, but due to hardware issues, I couldn't connect to iTunes right?

    From the responses, it sounds like I definitely caused this, but just curious if the hardware defect was what stopped me from fixing my mistake. Or is this a "brick your phone" mistake that I made regardless of the inability to restore through iTunes?
     
  6. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #6
    It's very likely user error that prevented you from being able to restore it via iTunes by means of DFU mode. A simple reset by holding down both buttons until the device restarts would result in the device restarting normally.
     
  7. megadon thread starter macrumors 6502

    Joined:
    Dec 5, 2008
    #7
    I did manage to reset the phone, but it would just start again with the apple logo with a progress bar that didn't move. I even managed to get it into DFU mode, but when connected to iTunes on my mac or my windows 7 laptop, iTunes would not recognize it at all. Something was preventing me from connecting to iTunes, but I feel like I tried every single way to reset the phone and connect through DFU to iTunes.. nothing worked..
     
  8. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #8
    You probably already had logicboard issues. There's a chip that regulates charging on the logicboard. If it's damaged there is no charging.

    I would presume it also would prevent recognition of your device as well.

    Once you threw the phone into the boot loop it exacerbated the problem because of the hardware failure.

    Note. If your charging cables are not Apple certified, I'd stop using them. It's been shown that non-Apple certified cables can blow this charge regulating chip on the logicboard.
     
  9. megadon thread starter macrumors 6502

    Joined:
    Dec 5, 2008
    #9
    Thanks for the info. I always assumed you can't brick your phone unless you root into it, and hopefully this was just hardware issues causing the inability to fix my mistake. Still sounds like I'll just be reading some stickies again for a while before doing it just to be sure I don't do something stupid again..
     
  10. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10
    Most likely it was a hardware issue if the Apple store couldn't DFU restore it either.
    But either way its JB 101. Never ever ever EVER do an erase all on a JB device.
    If You want to go back to stock then plug it to itunes and hit restore.
    But again, what you did would not cause permanent hardware damage.
    And no JB is not real easy or simple. People cannot follow directions and always want to cut corners, never educate themselves or bother researching at all. Until something happens and then they ask questions like what,why, how etc....
     
  11. stevelam macrumors 65816

    Joined:
    Nov 4, 2010
    #11
    you cant do "Erase data and settings in Settings > General > Reset > Erase all Content" on a jailbroken phone. this has been known for a long time now. best thing to do is just restore it and all would have been fine (minus the battery issue). if you're using ****** cheap 3rd party cables, that could probably fry the board too.
     
  12. Skizzy macrumors regular

    Skizzy

    Joined:
    Feb 4, 2013
    #12
    Seems like it was bound to happen at some point whether you decided to JB or not.
     
  13. boo-boo-butt macrumors member

    Joined:
    Nov 21, 2014
    #13
    Is it because erase all content basically wipes the encryption key to erase the drive quickly? I think that started with the 3GS. 3GS could erase almost instantly compared with the 3G which would take ages and do a full disk format.

    Or is it because of something else?

    I'm not trying to find a way to do it/justify it, I'm just curious.

    I can't seem to find an answer as to whether:

    1) the erase does actually go through and the device boot loops until you reinstall iOS by restoring via DFU

    or 2) the erase never actually happens and instead you get the boot loop but may be able to break out of it and get back to iOS...
     
  14. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #14
    I don't think its either of them. If I recall, the first time you launch Cydia it goes through the "Preparing File System" process. This moves a bunch of stuff around and as a result, the erase all content function no longer works properly leaving you with a phone that can have critical files deleted while others remain. Therefore you run into all sorts of issues.

    I could be wrong but I think I saw this over at reddit at some point a while back.
     
  15. boo-boo-butt macrumors member

    Joined:
    Nov 21, 2014
    #15
    Thanks!

    That makes sense.

    And it's interesting - does Cydia play a role in stopping erase working or the jailbreak process itself?

    Anyway, I'm restoring an iPhone 5 with 8.1 for testing this out. I'll try the erase contents option after jailbreaking but before loading Cydia and see. Granted, not many people will jailbreak without using Cydia so it's rather moot but I'm curious...
     
  16. boo-boo-butt macrumors member

    Joined:
    Nov 21, 2014
    #16
    Ok, here's what I did:

    1) Restored 8.1, did initial setup, jailbroke with Pangu v1.2.1(Windows)
    2) Changed phone name, took some photos, made some notes(to test erase)
    3) Erased all content and settings - phone rebooted a few times, then I got the Welcome/setup process screen
    4) Set up the phone and then opened Cydia. Cydia gives errors - not locked, no root access, etc - when refreshing sources. Nothing shows up in search. Rebooted and still the same issues
    5) Re-jailbroke with Pangu - got "timeout, please try again" error. Rebooted and retried a few times but got the same message
    6) Erased all content and settings again - stuck on Apple logo with progress bar at zero. Pangu picked it up and let me start the jailbreak so, what the hell, I clicked Jailbreak. It timed out just like before
    7) Rebooted in iTunes Restore mode, not DFU, and restored 8.1 stock

    Why did I do all that? For ****** and giggles, I guess :)
     
  17. bdawg98 macrumors newbie

    Joined:
    Nov 24, 2014
    #17
    So after I clicked "erase all content and settings" my phone went into a permanent loop of rebooting with no progress. iTunes would not recognize it tried DFU, different cord, different computer, even a windows computer, no luck.
     
  18. boo-boo-butt macrumors member

    Joined:
    Nov 21, 2014
    #18
    What happens if you turn it off then let go of both buttons then hold just the home button when you see the Apple logo?
     
  19. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #19
    Yes, pretty much what happens when you first open cydia from what I remember too
     
  20. RTony macrumors member

    RTony

    Joined:
    Sep 13, 2014
    #20
    Nice step by step guide, but I'd recommend following the proper guide with images and explanations just to be safe. You know, better safe than sorry. This tutorial is decent: http://www.latestapplenews.com/help/how-to-jailbreak-your-iphone-ipod-ipad-ios8
     
  21. boo-boo-butt macrumors member

    Joined:
    Nov 21, 2014
    #21
    Thanks, but it's not a guide. Really. It's just a list of things I did :)

    I wanted to find out what part of the jailbreak process caused the 'erase content' boot loop and if there was a way to somehow recover from it.

    Why? Because I wanted to know if a device stuck in the 'erase content' boot loop has actually erased the content or not for security reasons. E.g. What if someone causes the boot loop, thinks they can't fix it and sells the iPhone on eBay with their personal data intact? I didn't test if ssh is possible during the boot loop, for example.

    If anyone follows this thinking it's a jailbreak guide, then they should really pay attention to the thread which isn't even that long.
     

Share This Page