Bad iPhone?

Mel8899

macrumors 6502
Original poster
Sep 15, 2017
259
134
Since I got my iPhone 8 it’s had some issues. First when I text is was so slow, took awhile before letter would pop up after I pressed it. Second it gets stuck on landscape mode and I have to close app and start again. Third when I turn to vibrate it takes awhile before it actually does it. Also when I try to download an app it usually doesn’t work and I have to turn phone off and on.

Of course none happen all the time. Anyone else having theses issues?
 

Sharkoneau

macrumors 6502a
Jan 13, 2017
665
527
Michigan
Since I got my iPhone 8 it’s had some issues. First when I text is was so slow, took awhile before letter would pop up after I pressed it. Second it gets stuck on landscape mode and I have to close app and start again. Third when I turn to vibrate it takes awhile before it actually does it. Also when I try to download an app it usually doesn’t work and I have to turn phone off and on.

Of course none happen all the time. Anyone else having theses issues?
Along with @Mr_Brightside_@ , I too would suspect this to be a software issue. I've had some problems with keyboard lag here and there, and I have a 7. I've also heard here and there about the volume switcher delay. Have you updated your phone since receiving it?
 

Mel8899

macrumors 6502
Original poster
Sep 15, 2017
259
134
Backup to iCloud or iTunes and restore.
I have done this twice. Whenever I talk to apple they tell me this.
Along with @Mr_Brightside_@ , I too would suspect this to be a software issue. I've had some problems with keyboard lag here and there, and I have a 7. I've also heard here and there about the volume switcher delay. Have you updated your phone since receiving it?
I’m on the newest IOS. Never had issues on my 7
 

Sharkoneau

macrumors 6502a
Jan 13, 2017
665
527
Michigan
I have done this twice. Whenever I talk to apple they tell me this.


I’m on the newest IOS. Never had issues on my 7
The thing with restoring from backup is that if your backup is corrupted in any way, the problem will just carry over again. Pain the butt, but have you set up as new?