Bad Micro SD cards driving me nuts. Help?

Discussion in 'MacBook Pro' started by FirePak, Sep 18, 2009.

  1. FirePak macrumors regular

    Joined:
    May 5, 2006
    Location:
    Mesa Arizona
    #1
    So for the past few weeks I've been having some weird issues with 5 or so Micro SD and SDHC cards. I have a original Intel Macbook pro and a Asus EEE PC 1000HE. I have Micro SD cards ranging from 1gb cheap sandisk to 8gb class 6 transcend cards. None of them will mount in any of my devices.

    I have tried formatting them in Windows/Leopard and in linux using both ubuntu and gparted live disks. The cards mount fine in all operating systems but when I goto put them in my phone or in a DS or a camera they will not mount. I have also tried the internal sd slot on my EEE and 2 usb adaptors on my mac. Im completely stumped as to whats going on? I just dont see how new and old cards and 5 of them could be completely borked.

    Sorry so long Thanks in advance.

    I guess i should also mention that Im running snow leopard and it seems my issues may of started when I switched but im not certain.
     
  2. airplaneman macrumors 6502a

    Joined:
    Jun 8, 2009
    Location:
    USA
    #2
    Could there be dirt on any of them or in the card readers?
     
  3. mrmayor92 macrumors 6502

    Joined:
    Jul 12, 2008
    Location:
    PA
    #3
    you could try reinstalling snow leopard... or you could just take it to an apple if that doesnt work
     

Share This Page