Bad performance 2010 i5 17"

Discussion in 'MacBook Pro' started by cupcakes2000, Mar 27, 2011.

  1. cupcakes2000, Mar 27, 2011
    Last edited: Mar 28, 2011

    cupcakes2000 macrumors 6502

    Joined:
    Apr 13, 2010
    #1
    Hi,

    I have read MANY threads on this, but I thought I'd start another one about mine.

    I have a MBP 17" i5 running 10.6.7. (6,1-mid 2010)

    8gb of self installed Crucial memory.

    500gb 7200 Seagate Momentus XT, also self installed.

    I brought it to replace my ageing 2007 white MB.

    c2d-2.16-running 10.6.7.

    3gb self installed crucial memory.

    500gb 7200 WD self installed.

    I used/use them both mainly for photo/video work.

    I mainly run

    Aperture 3

    CS5 (most of it)

    Final Cut

    Iphoto

    That's the background.

    This is the problem.

    For the spec of the MBP, I get the spinning wheel of death far to often.

    When I first got it, I was shocked at how slow it seemed when processing stuff in PS. Even just enlarging the canvas, not even the image, could take a few minutes.

    Just navigating aperture could invoke it. It takes several seconds for the loupe to become good quality whilst checking for CA at 100%. You can't work like this.

    I will admit that these are large 7D raws, although my Aperture library is quite small. The reason being that I use iPhoto as my main library for everything, and only keep the very best in Aperture.

    I have noticed this wheel of death occurrence has slowly started to effect my machine system wide.

    iPhoto (although this has some 12000 photos in it), Safari, even just Finder sometimes!

    For example, watching catch up tv websites in Safari is jerky, always buffering, always freezing, often needing a force quit. I'll admit that this sounds like it should be my connection, or a Flash related problem, or even the site might be overloaded at the time. Except I can turn on my considerably less powerful MB, at the same time, and watch smoothly!

    I have done some trouble shooting. (In no particular order).

    Reinserted the old ram.

    Reinstalled SL (Fresh).

    Ran Onyx/Disk Utility etc.

    Permanently kept on the nVidia graphics.

    Turned off Spotlight (Why should I have to do that?).

    Tried to install the firmware update 1.9. It's made for my model (I checked) but it wont install, simply saying 'This software is not supported by your system'.

    I even tried to contact Apple support via their site. I couldn't though. They asked me to register it. I thought I had, but I tried anyway. Got al the way through and it said to check the purchase date because it 'couldn't be registered'.
    I checked my emails, and I have one from Apple saying 'Welcome to your new mac', dated the day I got it. So I did register it! I looked on my profile....no mention off it.

    AAARRRRGGGHHHHHHH.

    Any ideas?

    I don't have AppleCare. I have never needed it! All these years! My bad I guess.

    Joe
     
  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #2
    You need to watch Activity Monitor to find your bottleneck. Also, check /var/log/kernel.log and watch for disk0 I/O errors. Are you out of RAM? Is your processor pegged? Are there processes other than what you're doing chewing up all of your processor time?


    Check your warranty status here: https://selfsolve.apple.com/agreementWarrantyDynamic.do

    Are you under warranty? Do you have a receipt to prove it?
     
  3. gullySn0wCat macrumors 6502

    Joined:
    Dec 7, 2010
    #3
    Sounds like a dying HDD to me. Try switching it out.
     
  4. mrwonkers macrumors 6502

    mrwonkers

    Joined:
    Oct 31, 2004
    Location:
    Cyberia
    #4
    Upgrade the firmware on your Seagate Momentus XT hard drive to SD24 if problems persist put the original ram back in. If problems still persist put the original HD back in, if still no joy take your MBP to see a "genius" [I use the term loosely/ genius usually refers to some spotty git who was employed because he/she was the best of a bad bunch who were interviewed/don't be rude as the "genius" will get his/her hackles up thinking u wanto steal their playlunch - talk slowly be polite but DON'T back down till a satisfactory resolution is presented]
    good luck.
     
  5. cupcakes2000 thread starter macrumors 6502

    Joined:
    Apr 13, 2010
    #5
    Cheers for the info guys.....


    My mac is fairly clean other than what I said in the original message, I only have a couple of other apps on it. There is no bottle neck according to the activity monitor, and no random processes running either.
    I have 8gb of ram. I wouldn't of thought I was out, I only tend to run one or two things at a time. It sometimes occurs in Finder, just after waking up.

    I can't check my warranty, according to Apple it's not registered, but it is. Check my original post. I do have the receipt though, and I got it 05/08/10, so should still be under warranty.


    Tried it. Forgot to say in original post....

    Haven't tried firmware upgrade on the Seagate!! Will try (fingers crossed!!)

    Tried the original ram.....tried the original HD too.

    I live in the middle of nowhere in the French Alps atm, There are no Apple stores around. There is a reseller about 80 miles away, which I'll have to try if I can't get any net solutions. Prob have to send it away.



    Thanks for all your answers. Anyone Know what may be going on with the registered/not registered issue?
     
  6. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #6
    The lack of registering shouldn't cause your warranty not to exist. That's strange.

    A bad hard drive can definitely slow things down, but it would likely show up in /vat/log/kernel.log as I/O errors. It's also possible that either read or write speeds are just way down, but if you've swapped drives, you've accounted for this.

    Don't assume that you have enough RAM just because you have 8GB.

    A bad logic board can slow things down, but generally, it shows up in Activity Monitor as the kernel task chewing up processor time.

    You need to run actual tests to find the bottleneck. Until then, all anyone has to go on is that "it" is slow without knowing what "it" is.
     
  7. cupcakes2000 thread starter macrumors 6502

    Joined:
    Apr 13, 2010
    #7
    Well i have just updated the firmware on the HD so i'll see how it goes.

    I'm not assuming I have enough ram, but the MBP is not performing much better than the computer that it replaced. If you look at the spec difference then you'll see my concern. I'm doing the same things on both.

    So thanks i'll run 'actual tests' to find out what 'it' is shall I?

    Why do you think I'm asking for advice? Any idea what 'actual tests' I should be running?

    Lack of registering probably doesn't cause my warranty not to exist.
    That's not what I said.
    I can't look at the warranty without registering though, and I can't register because I already have registered. It just doesn't seem to realise on the system. It's confusing but that's whats happened.
     
  8. cupcakes2000 thread starter macrumors 6502

    Joined:
    Apr 13, 2010
    #8
    If anyone understands this, they could maybe tell me if this answers any questions.

    I ran Xbench.

    I had no other apps running other than gfxcardstatus, which was switched to Nvidia only.

    The result seems very low. Especially when compared to this dude.



    Results 112.67

    System Info
    Xbench Version 1.3
    System Version 10.6.7 (10J869)
    Physical RAM 8192 MB
    Model MacBookPro6,1
    Drive Type ST95005620AS

    CPU Test 169.93
    GCD Loop 314.61 16.58 Mops/sec
    Floating Point Basic 177.51 4.22 Gflop/sec
    vecLib FFT 87.58 2.89 Gflop/sec
    Floating Point Library 302.22 52.63 Mops/sec

    Thread Test 483.61
    Computation 506.01 10.25 Mops/sec, 4 threads
    Lock Contention 463.11 19.92 Mlocks/sec, 4 threads

    Memory Test 327.57
    System 379.26
    Allocate 840.75 3.09 Malloc/sec
    Fill 224.41 10911.40 MB/sec
    Copy 441.59 9120.80 MB/sec
    Stream 288.27
    Copy 287.11 5930.18 MB/sec
    Scale 284.94 5886.74 MB/sec
    Add 293.05 6242.69 MB/sec
    Triad 288.10 6163.18 MB/sec

    Quartz Graphics Test 156.86
    Line 208.47 13.88 Klines/sec [50% alpha]
    Rectangle 283.48 84.63 Krects/sec [50% alpha]
    Circle 232.09 18.92 Kcircles/sec [50% alpha]
    Bezier 216.95 5.47 Kbeziers/sec [50% alpha]
    Text 68.34 4.27 Kchars/sec

    OpenGL Graphics Test 185.93
    Spinning Squares 185.93 235.86 frames/sec

    User Interface Test 298.92
    Elements 298.92 1.37 Krefresh/sec

    Disk Test 27.76

    Sequential 54.27
    Uncached Write 105.81 64.96 MB/sec [4K blocks]
    Uncached Write 80.88 45.76 MB/sec [256K blocks]
    Uncached Read 25.96 7.60 MB/sec [4K blocks]
    Uncached Read 74.85 37.62 MB/sec [256K blocks]

    Random 18.65
    Uncached Write 5.50 0.58 MB/sec [4K blocks]
    Uncached Write 95.03 30.42 MB/sec [256K blocks]
    Uncached Read 64.66 0.46 MB/sec [4K blocks]
    Uncached Read 150.13 27.86 MB/sec [256K blocks]
     
  9. cluthz macrumors 68040

    cluthz

    Joined:
    Jun 15, 2004
    Location:
    Norway
    #9
    My Momentus XT also scores lower then the original HD, but I think xbench has an issue with momentus XT, since the machine is much faster with the XT. I think mine scored about 45 (not sure, I don't have it here atm, but I can check later today)

    My boot went from 45 ish secs to about 25 sec (from when i press the powerbutton).

    Try AJA Sytem Test (http://www.aja.com/products/software/)
    Be sure you Disable system cache!!
    My old drive scored about 65mb read and write with the standard drive, but over 100mb on the momentus xt.

    Btw your system should be performing same as mine, I have a 2010 15 inch i5 with 8GB Crucial RAM and also Momentus XT 500GB.

    Something is wrong, because the i5 is very snappy for me.
    I also use CS5 and with images that are close to 1GB it takes about 25 sec to load them, but once they are loaded i can zoom, enlarge canvas and it's about instant.

    How much HD space do you have free? You should aim to have atleast 10%-20% free for maximum performance.
     
  10. cupcakes2000 thread starter macrumors 6502

    Joined:
    Apr 13, 2010
    #10

    Well it can take up to a minute to load a 25mb raw, and then there is nothing snappy at all about general operations. Also, PS often stops responding. Especially when doing something intensive, like a large content aware fill, or liquify or something. Only option is to force quit _ I know this because I left the machine for about 20 minutes once, hoping it would sort itself out as I really didn't want to loose the work.

    I have 255gb free currently. Should be plenty!

    Boot time actually is generally quick actually, about the same as yours, and to be honest, the system wide probs I mentioned only occur maybe 50-60% of the time (still to much!).

    Intensive stuff is every time though.

    How do you use that AJA system test? I downloaded it, set it to read/write, disabled the cache, left it on 128mb file size, clicked the graph, then pressed 'start'. It turned to 'stop' for the briefest of seconds, then finished (well i presume...it went back to 'start')....but nothing showed on the graph??


    *EDIT*

    Sorry just been thick.....

    it is

    Read-69.7

    Write-54.8


    Hmmmm....def not over 100!!
     

Share This Page