Bad performance rMBP mid 2014

gbrug1995

macrumors newbie
Original poster
Feb 19, 2015
15
0
Hello,

Since september 2014 i've got myself a beautiful rMBP mid 2014.

specs:
2,5-GHz quad-core Intel Core i7-processor
16 GB 1600-MHz DDR3L
512GB SSD
Intel Iris Pro graphic processor
NVIDIA GeForce GT 750M with 2 GB GDDR5

And I've got the following problem. My Adobe collection of apps has always been VERY slow... Unusual slow. I use this macbook for school. And even a simple inDesign page ( few columns of text and a picture or 2) are too much to handle for this powerful macbook.

In adobe apps it lags like hell. Like 5 frames a second.

I got this problem when updating to Yosemite. Now on a second partition i downgraded to Mavericks. And the problem still persists....

How can I fix this? I can't send it to apple because i just can't do 2 weeks without my macbook for school...

Hope i'm clear enough.

Kind Regards,

Gino Brugman
 

soulreaver99

macrumors 68030
Aug 15, 2010
2,641
1,790
Southern California
Have you fixed disk permissions, reset PRAM, SMC etc (the usual drill)?

Do you only have this problem with Adobe software? I have light room and photoshop and they run perfectly fine. Even when I had the base model Macbook Air.
 

mlemonds

macrumors 65816
Apr 9, 2008
1,009
108
Lexington, KY
i have the base 15" rMBP 2014

i have also noticed lag with indesign, but the other apps seem fine. it lags a bit when scrolling through pages.
 

gbrug1995

macrumors newbie
Original poster
Feb 19, 2015
15
0
@soulreaver:

I did all that stuff. Did some osx reinstalls. Nothing fixes it... So annoying


Its for all the adobe apps. And the macbook just doesn't seem stable in performance. Sometimes Yosemite glitches and stuff.. Really annoying... But that might be Yosemite itself..


Even my classmate's MBA runs indesign and other adobe apps faster. How can a 999$ macbook air without discrete graphics card be faster than a 2500$ monster....
 
Last edited:

yjchua95

macrumors 604
Apr 23, 2011
6,725
230
GVA, KUL, MEL (current), ZQN
@soulreaver:

I did all that stuff. Did some osx reinstalls. Nothing fixes it... So annoying


Its for all the adobe apps. And the macbook just doesn't seem stable in performance. Sometimes Yosemite glitches and stuff.. Really annoying... But that might be Yosemite itself..


Even my classmate's MBA runs indesign and other adobe apps faster. How can a 999$ macbook air without discrete graphics card be faster than a 2500$ monster....
Have you update to 10.10.2 and also updated all your Adobe apps?

My entire Creative Cloud collection runs smoothly.
 

gbrug1995

macrumors newbie
Original poster
Feb 19, 2015
15
0
Have you update to 10.10.2 and also updated all your Adobe apps?

My entire Creative Cloud collection runs smoothly.
Yup, everything is up to date. I always look forward to new updates and if they get released i install them ASAP.

I also dumped my photoshop preferences to try to fix it. Didn't help tho.
 

Cardsnk

macrumors regular
Jul 18, 2013
139
12
What resolution are you using? is it best for retina? While using Adobe apps, if you are using scaled resolutions lag will be witnessed.
 

gbrug1995

macrumors newbie
Original poster
Feb 19, 2015
15
0
Hmm never thought of that. Ill give that a try thanks!

Im currently on 'more space' which is 2560 x 1440 i believe
 

gbrug1995

macrumors newbie
Original poster
Feb 19, 2015
15
0
Setting the resolution on Mavericks to the middle option, it becomes better. But still not fluid.

Ill report back to you guys with resolution on yosemite

Just did the same thing on Yosemite. Same effect as mavericks. Its a good temporarily workaround but not a 100% fix. Maybe this in combination with something else will do the trick?
 

Woodcrest64

macrumors 65816
Aug 14, 2006
1,169
327
This will fix it. Find the application, not the shortcut. Right click on it and go to INFO. Then check 'run application in low resolution'.

This will do it but your adobe apps won't run in retina mode but they will be liquid smooth.
 

gbrug1995

macrumors newbie
Original poster
Feb 19, 2015
15
0
This will fix it. Find the application, not the shortcut. Right click on it and go to INFO. Then check 'run application in low resolution'.

This will do it but your adobe apps won't run in retina mode but they will be liquid smooth.
Aha i see. Because im currently in "retina" according to my display settings, checking the run in low resolution will fix the complete problem?

Also. Anyone knows when adobe will fix this? I mean, come on... Muse offers to optimize websites for Retina, but the apps themselves won't run in retina? Seems a bit weird for me.

Thanks for all the help guys!
 

gbrug1995

macrumors newbie
Original poster
Feb 19, 2015
15
0
Just turned on the low resolution stuff for all the apps. And got my macbook running on yosemite with the display on the second last resolution. Seems to bed fixed for now! Hopefully Adobe comes with a retina fix or something.

Thank you all very much!
 

Woodcrest64

macrumors 65816
Aug 14, 2006
1,169
327
Just turned on the low resolution stuff for all the apps. And got my macbook running on yosemite with the display on the second last resolution. Seems to bed fixed for now! Hopefully Adobe comes with a retina fix or something.

Thank you all very much!
Anytime. Glad we could help :D