Bad screen tear in HL2 Portal

Discussion in 'Windows, Linux & Others on the Mac' started by mateus, Mar 2, 2009.

  1. mateus macrumors member

    mateus

    Joined:
    Sep 30, 2007
    Location:
    UK
    #1
    Hi,

    I've just installed Portal on my MBP with ATI X1600 (128mb) running XP SP2 via boot camp. While I've been able to play games like Far Cry with all settings on max without any problem :)cool:), Portal suffers from bad screen tear, even if settings are set low. :confused:

    Could this be a driver issue - I'm using the Apple drivers as I assumed these would be best?

    Or perhaps it's just a problem that this game suffers from.

    Cheers,
    M.

    EDIT: I should have put this thread in 'Apple Games'!
     
  2. LtRammstein macrumors 6502a

    LtRammstein

    Joined:
    Jun 20, 2006
    Location:
    Denver, CO
    #2
    Have you tried updating your ATI drivers? I know Valve, creator of Steam, tends to have issues with ATI cards. Best to search their forums for any issues retaining to your computer.
     
  3. mateus thread starter macrumors member

    mateus

    Joined:
    Sep 30, 2007
    Location:
    UK
    #3
    I've just tried the Omega drivers & they've helped - still tears but not as much & seems smoother.

    If you type "Portal screen" into Firefox's search box it suggests "Portal screen tearing" so it must be a problem although I can't actually find much info.
     
  4. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #4
    Screen tearing usually means too many frame rate per second. Look at your frame rate and see whether that's happening. If your frame rate is really high, try enabling
    - Triple Buffering
    - VSync

    Tweakguides.com has more info on the HL2 engine. (You really don't need to do any of it, but some info for reference)
     

Share This Page